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Preface

About This Guide

This guide gives instructions for installing PowerDOCS and 
provides the information you need to configure and maintain 
integration for the applications your users require. 

Who Should Read This Guide

This document is intended for the person who will be installing 
and configuring PowerDOCS.

How This Guide Is Organized

This book has five chapters and three appendices.

• Chapter 1: PowerDOCS Installation Overview

This chapter lists the workstation requirements and provides 
a checklist for you to follow to ensure that you perform all 
the necessary preinstallation and installation tasks.

• Chapter 2: Installing the PowerDOCS Admin Kit

This chapter describes the process you must follow to create 
the installation kit for your user workstations.

• Chapter 3: Installing PowerDOCS on a Workstation

Now that the Install Kit has been created, you must run the 
kit to install PowerDOCS on a workstation.
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• Chapter 4: PowerDOCS Implementation Tool

This chapter describes how you can use the PowerDOCS 
Implementation Tool to create a master registry file for future 
PowerDOCS installations.

• Chapter 5: Uninstalling DOCSFusion and PowerDOCS 
Components

This chapter provides brief instructions on uninstalling 
PowerDOCS.

• Appendix A: Configuring Application Integration for PowerDOCS

This appendix provides details on integrating your user 
applications with PowerDOCS.

• Appendix B: PowerDOCS E-Mail Integration

This appendix discusses integrating PowerDOCS with your e-mail 
system.

• Appendix C: DOCSFusion Security Regeneration Tool

This appendix briefly discusses using the DOCSFusion Security 
Regeneration tool.
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Documentation Conventions

This book uses the following fonts and styles to indicate different types 
of information. 

Related Manuals

In addition to this manual, you may find the following documents 
helpful.

• DOCS Designer and Data Dictionary - Explains enhancing DOCS 
Open with the DOCS Designer utility, including: creating forms, 
adding tables and columns, and adding and changing filters. 

• DOCSFusion 3.1 Setup and Administration Guide - Provides 
detailed instructions on installing and configuring your 
DOCSFusion server.

Convention Meaning

Regular Italic font Indicates a new term or variable in a
command line. For example, replace
filename with the name of a file.

Monospaced font Indicates a file, directory, drive or command
name, program code, or other text that
appears on the computer screen. For
example, the default Oracle library is usually
ORACLE_HOME/DBS or ORACLE_HOME/
RDBMS73.

Bold In instruction steps, indicates information
you must type. In text, indicates emphasis.

> Separates items on more than one
cascading menu or successive choices of
icons or program groups.
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Training Classes

Hummingbird (Document and Knowledge Management Solutions) 

offers courses at authorized Training Centers worldwide.  For more 

information or to register for classes, call Hummingbird Education 

Services at (613) 238-1761.

Where to Go for Information

On the Web Our website at http://www.hummingbird.com/support/dkm/  carries 

the most up-to-date information on DOCSFusion and PowerDOCS. 

This information is presented in technical bulletins and in 

WebSupport Solutions, each dealing with a specific topic that is not 

covered or that updates printed information. Before installing 

DOCSFusion/PowerDOCS, we suggest you browse through the 

bulletins for items that may be pertinent to your installation. For 

WebSupport, you will be asked to enter your user name and password 

for authentication. If you have not requested logon access to 

WebSupport, you can do so at http://www.hummingbird.com/

support/dkm/ .

On the Fusion
Family CD

The 3.5.1 Release Notes reside in the \PowerDOCS folder in a file called 

PowerDOCSReadme.rtf, which can be read by most editors and word-

processing programs. The release notes contain information that came 

to light after the documentation was printed. Known bugs and 

workarounds are also detailed in the Release Notes.

The 3.5.1 Release Notes reside in the \PowerDOCS folder in a file called 

PowerDOCSReadme.rtf, which can be read by most text editors and 

word-processing programs. The release notes contain information that 

came to light after the documentation was printed. Known bugs and 

workarounds are also detailed in the Release Notes. 



ON THE FUSION FAMILY CD

XI

The DOCSFusion product line’s online manuals, which are published 
in PDF format, are provided on the Fusion Family CD. To read these 
manuals, you will need a copy of Adobe Acrobat Reader installed on 
your machine. A setup program for Acrobat Reader 4.05 is provided on 
the DOCSFusion CD. If you do not already have a copy, follow the 
instructions below.  

1. Insert the Fusion Family CD in your computer’s CD-ROM drive.

2. The DOCSFusion Product Line Installation menu will be 
displayed.  Click Documentation.

3. Click  Install Acrobat Reader.  The Acrobat Reader version 4.05 
install program will launch.

4. Follow the onscreen instructions and install the program.  When 
complete, exit the DOCSFusion Product Line Installation menu.

The PowerDOCS manuals are found in the ..\Program 
Files\PCDOCS\PowerDOCS directory.  To access these manuals, start 
Acrobat Reader and select File>Open.  Navigate to the ..\Program 
Files\PCDOCS\PowerDOCS directory and select the file you want to 
open.

• PowerDOCS.PDF. The PowerDOCS User’s Guide

• PDInstall.PDF. The PowerDOCS Installation Guide

• PDAttache.PDF. The PowerDOCS Attaché User’s Guide
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To access the entire DOCSFusion documentation set:

1. Insert the Fusion Family CD in your computer’s CD-ROM drive.

2. The DOCSFusion Product Line Installation menu will be 
displayed.  Click Documentation.

3. Select Browse Documentation.  Double-click the PDFs directory. 

4. Double-click COVERDOC.PDF.  Acrobat Reader will launch and a  
menu listing the DOCSFusion documentation set will appear. 

5. To open a document, click the document name.  

The entire DOCSFusion product line documentation set, which 
includes the online manuals and the Windows Help files, can be 
installed on a network drive or any local machine. This gives you access 
to the documentation from the Start menu. To do this, follow steps 1 
and 2 above.  Select Install Documentation and follow the onscreen 
directions.

By default, the PowerDOCS Help files are installed with PowerDOCS.  
To access Help while using PowerDOCS, press F1.
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Technical Support

If you have questions about installing or administering PowerDOCS, 
you can contact Hummingbird Technical Support Department from 
8:00 A.M. to 8:00 P.M. EST. 

PowerDOCS Technical 
Support 

124 Marriott Drive

Tallahassee, FL 32301

Phone: 850.942.5000

Fax: 850.942.8085

Email: supportTLH@hummingbird.com

Asia/Pacific Technical 
Support

Level 12

80 Mount Street

North Sydney, NSW 2060

Phone: +61.2.9923.2011

Fax: +61.2.9922.3097

Email: SupportSyd@hummingbird.com

European Technical 
Support

2 rue Rouget de L'Isle

92137 Issy-les-Moulineaux, France

Phone: +33.1.46.29.07.40

Fax: +33.1.46.29.55.22

Email: support.eu@pcdocs.com
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PowerDOCS Installation Overview

In This Chapter

This chapter provides the minimum and recommended workstation 
requirements and a high-level overview of the entire PowerDOCS 
installation and configuration process.
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PowerDOCS Workstation Requirements

Make sure the computer where you will install the PowerDOCS 
components meets or exceeds the following specifications: 

Processor Recommended: Pentium 200+

Memory Recommended: 128 MB

Operating System Microsoft Windows NT Server 4.0 with
Service Pack 5 or later (required by the
DOCSFusion Server), Microsoft Windows
NT Workstation 4.0 with Service Pack 5.0 or
later, Windows 98, or Windows 2000.

Certified DOCS 
Open Libraries

DOCS Open 3.8 or later.

N O T E Your users must have a network domain account or a DOCS Open
Unplugged account with a password. They cannot log in to the
DOCSFusion server with a null password.

To use PowerDOCS Attaché, your users must have a DOCS Open
Unplugged account with a password.
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Checklist for Installing PowerDOCS

Use the steps below as a checklist to follow when installing and 
implementing PowerDOCS for your organization.

1. Complete all of the preinstallation tasks for DOCSFusion. See the 
DOCSFusion 3.1 Setup and Administration Guide. 

2. Run the combined setup program from the distribution CD. See 
the DOCSFusion 3.1 Setup and Administration Guide.

a. Install the DOCSFusion Server.

b. Install the DOCSFusion Client API.

c. Install the PowerDOCS Admin Kit component. Refer to 
“Running the PowerDOCS Admin Kit Setup” on page 6.

3. Make the PowerDOCS Installation Kit available in a user-
accessible location. See “Setting Up the PowerDOCS Client” on 
page 21.

4. Install the PowerDOCS client on a workstation to access the 
Interceptor Configuration Tool.

a. To install the PowerDOCS client on a Windows 95 
workstation:

i. Install DCOM for Windows 95. See “Installing DCOM on 
Windows 95 Workstations” on page 18.

ii. Run the PowerDOCS client installation. See “Setting Up 
the PowerDOCS Client” on page 21.

b. To install the PowerDOCS client on a Windows 98, Windows 
2000, or Windows NT workstation:

i. Run the PowerDOCS client installation. See “Setting Up 
the PowerDOCS Client” on page 21.

5. Configure end-user applications using the Interceptor 
Configuration Tool. See “Configuring Application Integration for 
PowerDOCS” on page 85.
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6. Once you have configured the applications, export this 
information to a registry file and give your users access to this file. 
This allows proper application configuration with no additional 
setup on individual workstations. See “Exporting the Interceptor 
Settings” on page 133.

7. Instruct each user to install the PowerDOCS client software by 
following these steps: 

a. To install the PowerDOCS client on a Windows 95 
workstation:

i. Install DCOM. See “Installing DCOM on Windows 95 
Workstations” on page 18.

ii. Run the PowerDOCS client installation. See “Setting Up 
the PowerDOCS Client” on page 21.

b. To install the PowerDOCS client on a Windows 98, Windows 
2000, or Windows NT workstation:

i. Run the PowerDOCS client installation. See “Setting Up 
the PowerDOCS Client” on page 21.

N O T E Adminstrators can use the Implementation Tool to create a registry
file for configuring items other than application integration. See
“PowerDOCS Implementation Tool” on page 43.



2
Installing the PowerDOCS Admin

Kit

In This Chapter

This chapter describes how to install the PowerDOCS Admin Kit. 
Follow the “Checklist for Installing PowerDOCS” on page 3. The 
instructions in this chapter assume that you are starting with the 
combined installation program for DOCSFusion Product Line as 
delivered on the distribution CD. If you are starting directly from the 
PowerDOCS Admin Kit installation program, skip past the first three 
steps on the next page.
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Running the PowerDOCS Admin Kit Setup

The PowerDOCS Admin Kit is the first component you must install 
after completing the DOCSFusion server installation (for information, 
see the DOCSFusion Installation Guide).

1. Insert the DOCSFusion Product Line CD into your CD drive. The 
DOCSFusion Product Line Installation Menu appears.  Select 
Install Products.

2. Select PowerDOCS.  The PowerDOCS Admin Kit welcome dialog 
box appears. 

Figure 2.1

PowerDOCS 
Admin Kit 
welcome dialog box
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3. Click Next to continue. The Software License Agreement dialog 
box appears. 

Read the agreement and click Yes if you agree to the terms. If you 
do not agree, click No and the setup program will terminate 
without making changes to your workstation.

Figure 2.2

PowerDOCS 
Admin Kit 
Software License 
Agreement dialog 
box
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4. The Licensing dialog box appears.  Type the serial number and 
password you received with this CD and click Next to continue.

Figure 2.3

PowerDOCS 
Admin Kit 
Licensing dialog 
box
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5. The Select Install Kit Type dialog box will appear.  Click on the 
type of Install Kit you want to create.  Your may choose between 
Typical and Custom. 

Select the type of installation you want to perform:

— Typical will install the components that are most frequently 
required for the majority of sites.

— Custom allows you to specify the components you require.

Figure 2.4

PowerDOCS 
Admin Kit Select 
Install Kit Type 
dialog box
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If you select the Custom option, the Select Components dialog 
box appears.  Select the components you want to install and click 
Next.

Figure 2.5

Select Components 
dialog box

N O T E The Microsoft Management Console (MMC) option copies the files
necessary for installation of the MMC. Refer to “Installing the
Microsoft Management Console” on page 45.
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6. The Choose Destination Location dialog box appears.

7. You may accept the default Destination Directory or select a 
different directory.  To select a different directory, click Browse.  

Figure 2.6

PowerDOCS 
Admin Kit Choose 
Destination 
Location dialog box

N O T E This will be the Install Kit directory that your users will need to
access to install the PowerDOCS client on their workstations.
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The Choose Folder dialog box appears. Select the desired folder 
and click OK.

Figure 2.7

Choose Folder dialog 
box
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8. The Start Copying dialog box will appear.   Ensure that the 
components shown are the appropriate ones and click Next to 
continue or click Back to return to the previous dialog box.

Figure 2.8

Start Copying 
dialog box



9. The installation program copies files to the target directory. 
When all files have been copied, the Setup Complete dialog box 
appears.

10. Click Finish to complete the installation. The PowerDOCS 
Admin Kit has been installed.

11. The DOCSFusion Product Line Installation Menu will appear.  
Click Main, then Exit

The PowerDOCS Admin Kit has created the directories for your users 
to install the PowerDOCS client software. You must ensure that they 
have access to this location (the default location is C:\Program 
Files\PCDOCS\Install). You can do this from the Windows 
Explorer by selecting the Install directory and opening the Properties 
dialog box (File>Properties), then setting the appropriate values on 
the Sharing tab.

Figure 2.9

PowerDOCS 
Admin Kit Setup 
Complete dialog box
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If you will be creating and exporting registry setting files using 
the Implementation Tool, Email Configuration Tool, and 
Interceptor, you can place these registry files in the installation 
directory (the default location is C:\Progam 
Files\PCDOCS\Install\PowerDOCS)and they will be 
included with the PowerDOCS client installation.
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3
Installing PowerDOCS on a

Workstation

In This Chapter

This chapter describes running the PowerDOCS Install Kit from the 
user’s workstation.

Windows 98, Windows 2000, and Windows NT users. If you are 
installing the PowerDOCS client on a Windows 98, Windows 2000 or 
Windows NT workstation, proceed to “Setting Up the PowerDOCS 
Client” on page 21.

Windows 95 users. Before you install the PowerDOCS client on a 
Windows 95 workstation, you must complete one task:

• Install DCOM for Windows 95.

The following section walks you through the preinstallation steps.
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Preparing Windows 95 Workstations

Installing DCOM
on Windows 95

Workstations

Before you install the PowerDOCS client on a Windows 95 
workstation, you must install DCOM. This is not required for 
Windows 98, Windows 200, or Windows NT workstations.

1. Open the DCOM folder located in the PowerDOCS Install 
directory (the default directory location is C:\Program 
Files\PCDOCS\Install).

2. Double-click Dcom95.exe. The following dialog box appears. 

N O T E If you do not install DCOM before starting the PowerDOCS Client
Install procedure, the PowerDOCS Install program will notify you that
DCOM needs to be installed.

Figure 3.1

DCOM for Windows 
95 confirmation dialog 
box
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3. Click Yes to continue. The license agreement is displayed. 

4. Click Yes if you accept the conditions stated. If you do not accept 
the license agreement, click No. The setup program will exit 
without making changes to your system configuration. 

5. When the DCOM files are finished copying, you are asked if you 
want to restart your computer.  Click Yes.

Figure 3.2

DCOM95 for Windows 
95 license dialog box
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Figure 3.3

DCOM95 for Windows 
95 reboot dialog box
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Setting Up the PowerDOCS Client

The PowerDOCS Admin Kit installation program creates a client 
installation kit for you to place on a user-accessible location on your 
network. After you create the installation kit, your users can run the 
PowerDOCS installation program to install the PowerDOCS client on 
their workstations.

1. Run the PowerDOCS Install Kit setup program (default is 
C:\Program Files\PCDOCS\Install\setup.exe).

2. The welcome dialog box for the PowerDOCS Install Kit appears. 

Figure 3.4

PowerDOCS Install 
Kit 3.5.1 welcome 
dialog box
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3. Click Next to continue.  The Software License Agreement dialog 
box will appear.  Click Yes to accept the terms of the agreement.

Figure 3.5

PowerDOCS Install Kit 
Software License Agree-
ment dialog box
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4. The Select Components dialog box appears. 

Select the components and click Next to continue with the 
installation: 

Figure 3.6

PowerDOCS Install 
Kit Select Compo-
nents dialog box

DOCSFusion Client API This provides the communications
path between client applications
and the DOCSFusion server and
must be installed on each user’s
workstation in order for
PowerDOCS to run.

PowerDOCS This is the client software for the
user’s workstation and includes the
PowerDOCS Desktop,
PowerDOCS Explorer, and Fulcurm
FulView. Fulcrum Fulview must be
installed to use the Viewer and
Profile Add-on features.
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5. The Start Copying Files dialog box appears. Ensure that the 
current settings are correct and click Next.  

Figure 3.7

PowerDOCS Install 
Kit Start Copying 
Files dialog box
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At this point, the PowerDOCS Install Kit begins to install the first 
component.  The DOCSFusion Client API welcome dialog box 
appears. Click Next to continue.

Figure 3.8

DOCSFusion Client 
API welcome dialog 
box
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6. The Software License Agreement dialog box appears. If you accept 
the conditions stated there, click Yes to continue with the 
installation.

Figure 3.9

DOCSFusion Client 
API Software License 
Agreement dialog box
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7. The Setup Type dialog box appears. 

Select a Setup option and click Next. 

You may accept the default Destination Directory or select a 
different directory.  To select a different directory, click Browse.  

Figure 3.10

DOCSFusion Client 
API Setup Type dialog 
box

Typical Installs the most commonly used options. This
option is recommended for initial installation and
for most users.

Compact Installs only those files required to run the
program.

Custom Lets you to specify the options you want
installed. This option is recommended only for
advanced users.
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The Choose Folder dialog box appears. Select the desired folder 
and click OK.

8. The Select Program Group dialog box will appear.  Click Next to 
continue.

9. The Start Copying Files dialog box appears. Verify the Current 
Settings you have chosen, and click Next to copy the DOCSFusion 
Client API files.

Figure 3.11

DOCSFusion Client 
API Start Copying 
Files dialog box
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10. After the files are copied to your machine, click Finish from the 
Setup: Reboot Required dialog box.   You computer will reboot.

Figure 3.12

DOCSFusion Client 
API Setup: Reboot 
Required dialog box
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11. After the computer has restarted, the DOCSFusion Client API 
install will continue.  The Setup Complete dialog box will appear.  
Click Finish.

12. The DOCSFusion Client API Configuration Wizard will launch.  
The Welcome screen will appear first.  Click Next to continue.

13. Enter your DOCSFusion Server Name in the space provided.  The 
field may already contain the name.  If not, contact your 
PowerDOCS administrator for this information.

If your organization utilizes the Fail-over and Load Balancing 
feature, check the FOLB box.

14. Click Next to continue.  Click Finish to complete the 
configuration.

Figure 3.13

DOCSFusion Client 
API Setup Complete 
dialog box
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15. The PowerDOCS 3.5.1 Install Program will launch.  The Welcome 
dialog box will appear first.

Figure 3.14

PowerDOCS Setup 
program Welcome di-
alog box
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16. Click Next to continue.  The Select Directory dialog box will 
appear. 

You may accept the default Destination Directory or select a 
different directory.  To select a different directory, click Browse.  

The Choose Folder dialog box appears. Select the desired folder 
and click OK.

Figure 3.15

PowerDOCS Setup 
program Select Di-
rectory dialog box
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17. Click Next to continue.  The Select Components dialog box 
appears. 

 The components from which you may select are as follows:

• Implementation Tool: This utility will help PowerDOCS 
administrators manage all aspects of the PowerDOCS product.  It 
allows you to create a single registry file that stores information 
about your PowerDOCS settings.  This registry file can then be 
distributed to desktop installations of PowerDOCS 3.5.1.

Figure 3.16

PowerDOCS Setup 
program Select Com-
ponents dialog box

N O T E Use of the Implementation Tool is restricted to DOCS_Supervisors.
Microsoft Management Console version 1.1 must also be installed.
Refer to “Installing the Microsoft Management Console” on page
45.
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• The PowerDOCS 3.5.1 Desktop: The Desktop serves as the 
program’s “home base” and allows you to view and act on the 
contents of PowerDOCS libraries. All functions and features are 
available from the Desktop. 

• The PowerDOCS 3.5.1 Explorer: This option puts the 
functionality of PowerDOCS Desktop into the Windows Explorer.

• Email Integration: This option puts the DOCSFusion document 
management functions into the Microsoft Outlook email client, 
the Novell GroupWise email client, and the Lotus Notes client. 

If you select Email Integration and you do not have a supported 
email client installed, the following information message will be 
displayed.  Click OK and deselect the Email Integration option.

Figure 3.17

Email Integration in-
formation message
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If you have installed one of the supported email clients, additional 
options (including message formatting) can be set.  Click the 
Change button.  After making your changes, click Continue. 

N O T E E-mail integration is required if you intend to install the Outlook Client.

Figure 3.18

PowerDOCS Setup 
Program Email Integra-
tion Component Selec-
tion

N O T E Installation of the Lotus Notes integration will require you to have at
minium, Designer level access to the Lotus Notes mail base on the
Domino Mail server.

If you have this access and have selected Lotus Notes e-mail
itnegration, you will be required to enter your Notes password
during the installation process. A DOS window will display and you
will not see a cursor. Type your password and press Enter. After
a short delay, the installation will continue.
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• Microsoft Outlook Client: Gives Outlook users the ability to use 
PowerDOCS libraries and documents from within Microsoft 
Outlook.  

• Passive Integration: This option adds DOCSFusion document 
management functions into Microsoft Word, Excel, Project 98, and 
Adobe Acrobat 4.0 applications. You can select which applications 
to integrate by clicking the Change button and selecting the specific 
applications from the dialog box..

If the computer on which you are installing PowerDOCS has never 
used the installed copies of Microsoft Word or Excel, it will be 
necessary to open the program at least one time to fill out and 
register the User Information.  If this registration process has not 

N O T E If it becomes necessary to use another integration type for an
application that was installed with Passive Integration, it will be
ncessary to uninstall PowerDOCS and reinstall PowerDOCS.

Figure 3.19

PowerDOCS Setup pro-
gram Passive Integra-
tion Component Selec-
tion
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been  performed prior to beginning the PowerDOCS Installation, 
the warning messages shown on the next page will be displayed. 
Open Word or Excel, complete the registration process and close 
the application.  Proceed with the PowerDOCS install.

• Microsoft Word AutoExec Macro: Installation of this macro 
prevents multiple instances of Microsoft Word being launched.

Figure 3.20

Passive Integration In-
stallation Warning - 
Microsoft Word and 
Microsoft Excel
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Make your selections and click Next.

18. If you have selected Microsoft Outlook Integration and if you 
want to save messages in MSG format, select Save message in MSG 
or RTF format. If you do not want to save messages in MSG 
format, select Save messages in RTF format only. 

19. Click Next to continue.  The Fast Start Selection Option dialog 
box will be displayed.  This option loads PowerDOCS in the 

Figure 3.21

PowerDOCS Setup 
program Select Op-
tion: E-mail Message 
Type dialog box
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background during Windows startup.  Select Yes to have this 
feature activated.  Select No if you do not want to use Fast Start.

Figure 3.22

PowerDOCS Setup 
program Select Op-
tion: Fast Start dialog 
box
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20. Click Next to continue.  The setup program has the information 
necessary to begin installing. The Start Copying Files dialog box 
shows the current settings. If you want to change anything, click 
Back. To continue with the installation, click Next.

Figure 3.23

PowerDOCS Setup 
program Start Copy-
ing Files dialog box
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21. The following message will be displayed, informing you that you 
will need to reboot your computer.  Failure to comply will cause 
PowerDOCS to function incorrectly. Click OK.

22. The message box shown below will be displayed.  Click Finish to 
proceed with the installation of the FulView application. 

Figure 3.24

PowerDOCS Re-
boot reminder mes-
sage

Figure 3.25

First Setup Com-
plete dialog box
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23. Click Finish to exit the installation program and start the Fulcrum 
FulView install procedure. 

24. The Fulcrum FulView Setup program Welcome dialog box will 
appear.  Click Next.

25. Fulcrum Fulview will be installed to your computer.  After the 
installtion has finished, restart your computer.

Figure 3.26

Second Setup Com-
plete dialog box
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PowerDOCS Implementation Tool

In This Chapter

This chapter explains how PowerDOCS administrators can use the 
Implementation Tool to centrally manage the entire PowerDOCS 
installation.
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The PowerDOCS Implementation Tool

The PowerDOCS Implementation Tool is designed to allow 
administrators to centrally manage the entire PowerDOCS Desktop 
installation by creating a set of registry snapshot files that represent the 
PowerDOCS settings on the administrator’s computer. This registry 
file can be placed in the PowerDOCS installation directory and 
automatically installed when the user installs PowerDOCS.  
Alternately, the registry files can be provided to users who then merge 
these settings into their local registries.

The Implementation Tool includes configuration of the PowerDOCS 
User Interface, custom forms, add-ons, and plug-ins.

The Implementation Tool works from within the Microsoft  
Management Console (MMC) utility. MMC version 1.1 must be 
installed on your computer in order to use the Implementation Tool 
and Email Integration. The MMC install kit is included as part of the 
standard DOCSFusion Family setup. Installation instructions are listed 
on the next page.

In addition to having the MMC installed, you should be a DOCS Open 
Supervisors Group member.
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Installing the
Microsoft

Management
Console

The installation files for the Microsoft Management Console are copied 
into the PowerDOCS installation directory when the PowerDOCS 
Admin Kit is installed.

1. Locate the MMC installation directory.  The default location is 
C:\Program Files\PCDOCS\Install.  Double-click  the file 
IMMC.exe.  The Microsoft Management Console Setup Welcome 
screen will appear.

2. Click Next. The License Agreement dialog box appears.  If you 
agree to the terms of the license, click Agree, then click Next. 

Figure 4.1

Microsoft Manage-
ment Console Setup 
Welcome Screen
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If you do not agree with the terms of the license, click I Disagree.  
The installation program will terminate.

Figure 4.2

Microsoft Manage-
ment Console License 
Agreement
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3. The Setup dialog box will appear.  Enter your name and company 
information.  Click Next.

Figure 4.3

Microsoft Manage-
ment Console Setup di-
alog box
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4. The installation will proceed.  When complete, the following 
dialog box will be displayed.  Click Finish to exit the installation 
program.

Starting the
Implementation

Tool

The Implementation Tool is accessed through the PowerDOCS 
Program Group.

On your Windows desktop, click Start>Programs>PowerDOCS3.5.1

1. Select Implementation Tool.

Figure 4.4

Microsoft Manage-
ment Console installa-
tion complete dialog 
box

N O T E You must have administrator rights to your computer to use the
PowerDOCS Implementation Tool.
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2. The Microsoft Management Console will launch.

3. Click the plus sign to expand the PowerDOCS Admin Central tree.

4. Click to expand the Plug-ins tree. If necessary, log in to 
PowerDOCS.

Figure 4.5

The Implementation 
Tool Welcome Screen
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5. Continue expanding the tree until you can view all the options 
available to you.

6. Select each option by clicking it one time. Detailed descriptions of 
each option follow.

Figure 4.6

PowerDOCS Imple-
mentation Central Op-
tions
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The Plug-ins Configuration Screen

A plug-in is an extension module that provides additional functionality 
to PowerDOCS. All registered plug-ins will be shown in the same order 
as their respective InsertAt registry entry. If you have more than one 
plug-in installed, you can change the load order of the plug-in.

Highlight the plug-in and use the up and down arrows to move its 
position within the list.

Figure 4.7

Plug-Ins Configuration 
screen
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Document Management Configuration

There are three tabs of information in Document Management 
Configuration:

• General

• Log

• Performance

The General Tab

Basic document management settings are found on the General tab.

Figure 4.8

The General tab - Doc-
ument Management 
Configuration
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1. The Download folder displays the folder where temporary 
documents will be created. Specify an exact path or use an 
environment variable such as %Temp% to specify the temporary 
directory. The lookup button can be used to browse for the desired 
directory.

2. Settings for Quick Searches and Projects allow you to use the same 
column listing for all projects and all quick searches. Check the 
desired boxes.

3. Use the Quick Search List spinner box to change the number of 
documents listed in the Search Results list. You can also manually 
enter an integer in this space. 

4. To change the documents displayed in the Recently Edited 
Documents list (RED), you have the option to use the default 
DOCSFusion RED or deselect the default option and indicate the 
number and age of documents displayed in the Recently Edited 
Documents list.

When DOCSFusion RED is used, the user can’t control the 
number of documents that will be retrieved, all documents edited 
in the last 90 days will be shown.

N O T E If the Quick Search returns more items than the list box is
configured for, the results set will be truncated.
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The Log Tab

The Log tab allows you to enable logging and set the location of the log 
file. It is recommended that you do not enable logging full-time, as it is 
usually only used to track system information for the purposes of 
troubleshooting problems.  The log file created with this option records 
activity on the Fusion server.  An example of this log is shown below.

Click the Log Options check box to enable. Enter the full path for the 
log file or use the lookup button to browse for the file location. It is 
recommended that the file name you give this file be unique so that it 
can be distinguished from other log files created by PowerDOCS.

Figure 4.9

Fusion activity log file

Fusion plugin Log file. Compiled at Jan 26 2000,  
13:28:29

Running on Windows NT 4.0. Build N 1381. 
CSDVersion: Service Pack 5

Time PrId ThrId    Mask Description

09:11:54.31 312 136 00000010 Application 
constructor: 0x30136C

09:11:54.38 312 136 00000010 Running on WinNT

09:11:54.67 312 136 00000040 Fusion CSI Threads - 
0x0

09:11:54.67 312 127 00000040 DDEServer: init 
succeeded

09:11:55.47 312 136 00000020 Fusion Client API 
has been loaded.

09:11:55.47 312 136 00000020 Executing first 
fusion call

09:11:55.81 312 136 00000020 Successfully returns 
from first fusion call
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Figure 4.10

The Log tab - Docu-
ment Management 
Configuration
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The Performance Tab

Use the Performance tab to set Cache and Chunk Factor settings.

1. The Cache folder is the location where cache data will be stored. 
Use the lookup button to browse for a different file location.

2. To cache lookups and users and groups, select the check boxes 
shown. Caching users and groups will cache the list used in the 
Access Control list.

3. The Cache Level list specifies the amount of data to be cached. 
There are four options:

• No pre-caching

• Balanced pre-caching

• Maximum pre-caching

• Custom pre-caching

Figure 4.11

The Performance tab - 
Document Manage-
ment Configuration
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4. The settings for each of these Cache Levels are stored in the Cache 
Settings dialog box. Click Settings to view the dialog box, as shown 
in Figure 4.12.

Inspect the four settings by selecting them from the Cache Level 
list. For each of the four settings, you can modify the Pre-Cache 
parameters.

5. You can set the number of document types, items in lookup, and 
items on a list to be cached.

6. The cleanup of shadowed documents can be controled from the 
Clean Shadow check box.  Please refer to the section titled “Clean 
Shadow Check Box” on page 60.

Figure 4.12

Cache settings
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7. Individual lookup settings can be changed by making changes to 
the Cache Lookups dialog box. From the Cache Settings window, 
scroll down until you can see the Lookups setting.

8. Click the Lookup button to view the Cache Lookups dialog box. 

Click to select or deselect the lookup options.

Figure 4.13

Lookups Setting - 
Cache Settings

Figure 4.14

Cache Lookups dialog 
box
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9. The Cache lookups default dialog box settings will change 
depending on which Cache level was selected. The available 
choices are:

10. The “Cache on all forms” check box indicates whether lookups 
will be cached on all forms or only on the GROUP_DEF. By 
default, the check box is unchecked for Cache Level None or 
Balanced.

11. Press OK to accept these settings or click Cancel to disregard any 
changes that you have made.

Parameter Description / Database Table

Applications APPS

Authors PEOPLE

Document Types DOCUMENT TYPES

Keywords %KEYWORDS

Library standard
specific

CLIENT, MATTER, USER_ORG,
USER_DEPT

Other All other lookups including custom ones
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Clean Shadow Check Box

If the Clean Shadow check box is left blank, PowerDOCS will not delete 

shadow documents during startup and will only delete shadow 

documents when specifically given the command to do so by selecting 

Options>Delete Shadowed Documents.

If the Clean Shadow check box is selected, PowerDOCS will clean 

shadowed documents according to the Cleanup Options section of 

Groups>DOCS Unplugged in Library Maintenance.  These settings are 

as follows:

• Force Cleanup of Shadowed Documents: This field is disabled if 

Shadow Documents to Local Library is set to "No."  Check this box 

to have PowerDOCS automatically purge shadowed documents 

from the local drive. Documents that are older than the Minimum 

Age For Delete (specified below) are deleted each time you start 

PowerDOCS. 

• Minimal Age For Delete (Days): This field is disabled if Shadow 

Documents to Local Library is set to "No."  Enter the minimum 

number of days you want documents to remain on the local drive 

without being edited before being deleted. 

• Minimum Local Disk Space (MB): Enter the minimum allowed 

disk space on the local drive before shadowed documents are 

purged. If Force Cleanup of Shadowed Documents is set to “Yes,” 

the purge will be run automatically. If it is set to “No,” the users will 

be notified with a message that they should purge shadowed 

documents. The default value is 5 MB.

The Cleanup Options listed above work in conjunction with other 

Library Maintenance settings.  The chart shown on the next page gives 

examples on how these settings work together to control document 

shadowing.
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For more information on these Library Maintenance settings, please 
refer to the Library Maintenance Help System or the DOCS Open 
Administrator’s Guide.

Forms Configuration

Use the Custom Forms section to designate which custom forms 
PowerDOCS should display. 

By default, each form is set to use the default PowerDOCS internal 
form.

To change to a custom form:

1. Select the form name from the Forms list.

N O T E You must use the PowerDOCS Application Program Interface (API)
Toolkit to create or modify custom forms.

Figure 4.15

Custom Forms Config-
uration screen
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2. Enter the CLSID or ProgID of the form in the CLSID or ProgID 
field.  CLSID and ProgID entries are found in the Windows 
Registry under HKEY_CLASSES_ROOT 

A CLSID is a universally unique identifier (UUID) that identifies a 
type of Component Object Model (COM) object. Each type of 
COM object item has its CLSID in the registry so that it can be 
loaded and used by other applications. For example, a spreadsheet 
can create worksheet items, chart items, and macrosheet items. 
Each of these item types has its own CLSID that uniquely identifies 
it to the system. 

A ProgID, or programmatic identifier, is a registry entry that can 
be associated with a CLSID. The format of a ProgID is 
<Vendor>.<Component>.<Version>, separated by periods and 
with no spaces, as in Word.Document.6. Like the CLSID, the 
ProgID identifies a class, but with less precision.
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Event Handlers Configuration

Event handlers are custom components that extend the PowerDOCS 
menu and provide additional functionality. You can change the load 
order of the event handlers in this section.

1. Select the event handler whose load order you want to modify.

2. Click the up or down arrows to the right of the event handler 
name.

Figure 4.16

Event Handlers Config-
uration Screen
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Integration Schemes Configuration

The Integration Schemes configuration section is located within the 
Application Integration folder. Using this section you can enable or 
disable an integration scheme and change the schemes load order.

1. To disable or enable an integration scheme, click the checkbox to 
the left of the scheme type.

2. To change a scheme’s load order, click the scheme name then use 
the up and down arrow buttons to the left of the screen.

Figure 4.17

Integration Schemes 
Configuration Screen
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E-mail Integration

E-mail Integration configuration can be configured in this section of 
the Implementation Tool.   Prior to configuring e-mail integration in 
the Implementation Tool, read Appendix B on page 155.

E-mail
Integration

Configuration

1. Select the Integration type from the drop down list.

 This entry can have the following values:

• None: No integration available.

Figure 4.18

E-mail Integration 
Configuration Screen
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• Normal: This integration does not store message parameters. The 
messages and attachments are stored in PowerDOCS as simple, 
separate documents.

• Enhanced: This integration method supports the storing of 
message parameters (for example: MAIL_ID, ATTACH_NUM, 
MSG_ITEM, DELIVER_REC, PARENTMAIL_ID and 
THREAD_NUM).

2. Select the E-mail Group from the drop down list.  This entry 
contains the E-mail User Group Name from PowerDOCS. This 
helps to maintain Security.

3. Select the Profile form to be used for messages being saved to 
PowerDOCS. 

4. To enable MSG format messages for use with Microsoft Outlook, 
click the checkbox labeled Enable MSG format.

5. To allow document names to be duplicated when saving e-mail, 
click the checkbox labeled Duplicate document names. This entry 
must correspond to the PowerDOCS database settings - to allow 
PowerDOCS to duplicate document names or enforce unique 
document names. This entry can have the following values:

— Checked. Allows multiple PowerDOCS documents to have the 
same document name.

N O T E Enhanced integration is only available for Microsoft Outlook. For
Lotus Notes and GroupWise email integration, select Normal or
None.

N O T E The group you choose will be added to the Current Trustees list for
Document Access if you select the Grant Access to Email Users
Group for the Apply Security combo box of the Save Email to
DOCS Open dialog box.

N O T E If you selected MSG and RTF format for e-mail messages during the
PowerDOCS install, this feature will already be enabled.
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— Unchecked. Requires that PowerDOCS document names be 
unique.

6. To set the Document type and Application for RTF messages, 
MSG messages and unknown attachments you must select each 
option in turn.  These entries must be valid on the DOCUMENT 
TYPES table. Messages will be saved with Document Type and 
Application values in PowerDOCS. You can check their values in 
Library Maintenance (Document Types and Application lookups).

7. Using the drop down list, select a Document type for RTF 
messages.

8. Using the drop down list, select an Application to be associated 
with RTF messages.

9. Repeat steps 7 and 8 for MSG messages and unknown 
attachments.
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E-mail
Integration -

Header Fields

The Header Fields tab allows you to assign email header information to 
a field on the Profile form.

Select a SQL Column name from the drop down list attached to each 
header field name. For example, if you want to use the ABSTRACT field 
as a source for the Subject field, select the ABSTRACT column from the 
drop down list.

Figure 4.19

E-mail Integration 
Configuration - Header 
Fields tab
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E-mail
Integration -

Dialog Options

The Dialogs tab allows you to configure Save Options, Attachment 
options and Insert Options for email integration.

1. Save message body check box indicates whether or not the Save 
main message field of the Save to PowerDOCS dialog is checked 
by default.

2. Save attachments check box indicates whether or not the Save 
attachments field of the Save to PowerDOCS dialog is checked by 
default.

3. Delete e-mail after save check box indicates whether or not the 
Delete original document after save field of the Save to 
PowerDOCS dialog is checked by default.

4. The Attachment name drop down list can have one of the 
following values:

Figure 4.20

E-mail Integration 
Configuration - Dialogs 
tab
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— Custom. Indicates that the user must specify the name of each 
attachment separately when profiling it.

— Subject. Indicates that the name of all attachments will be 
defaulted to the message subject.

— File name. Indicates that the name of all attachments will be 
defaulted to their file names.

5. The Send drop down list indicates the default value shown in the 
Insert Type column of the Insert from PowerDOCS window. The 
choices are:

— Copy

— Copy and check-out

— Reference

General Options

The General Options section allows you to enable logging and set the 
location of the log file. It is recommended that you do not enable 
logging full-time, as it is usually only used to track system information 
for the purposes of troubleshooting problems.  The log file created with 
this option records activity on the DE Core.  An example of this log is 
shown on the next page.  
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Figure 4.21

Log File

DE Core Log file. Compiled at Jan 26 2000,  

13:28:29

Running on Windows NT 4.0. Build N 1381. 

CSDVersion: Service Pack 5

Time PrId ThrId    Mask Description

09:11:48.10 312 136 00000100 Event 

<SHELL_INSTANCE_STARTING> <0x44> was created 

successfully

09:11:48.10 312 136 00000100 Creating main window 

with HWND = 0x200ea

09:11:55.81 312 136 00000100 Event 

<SHELL_INSTANCE_STARTING> <0x44> was closed 

successfully

09:12:46.87 312 136 00000100 Browser Core 0x302F30 

- created

09:12:46.87 312 136 00000180 Loading plugins

09:12:46.87 312 136 00000180 Plugin key: Fusion

Figure 4.22

General Options Screen
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Click the Log Options checkbox to enable. Enter the full path for the 
log file or use the lookup button to browse for the file location. It is 
recommended that the filename you give this file be unique so that it 
can be distinguished from other log files created by PowerDOCS.

Add-ons Configuration

An Add-on is a PowerDOCS user interface extension. Using this 
section you can enable or disable add-on products or change their load 
order.  

For more information on the Profile and Viewer Add-ons, refer to 
“Viewing a Document or Profile Using PowerDOCS Add-Ons” in the 
PowerDOCS User’s Guide.

1. Click the checkbox to enable or disable an Add-on application.

2. Select the Add-on whose load order you want to modify.

Figure 4.23

Add-ons Configuration 
Screen
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3. Click the up or down arrow to the right of the window to change 
the Add-on position in the PowerDOCS window.

Custom Tabs Configuration

Use the Custom Tabs section to manage custom tabs that appear in the 
PowerDOCS Desktop.

To rename a custom tab, click on the tab name and enter a new name.

To enable a custom tab, click the checkbox next to the tab name. To 
disable a custom tab, click the checkbox to clear it.

N O T E The Logger Add-on should only be activated at the request of
Hummingbird Techinical Support.

Figure 4.24

Custom Tabs Configu-
ration Screen

N O T E You must use the PowerDOCS Application Program Interface (API)
Toolkit to create or modify custom tabs.
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PowerDOCS Desktop Configuration

General Desktop options such as Refresh rate and automatic selection 
of the first item in a Search Results list can be set in this section.

The Refresh Time is the number of minutes between instances when 
the PowerDOCS pane is refreshed. You can use the spinners to increase 
or decrease the Refresh time in increments of one. You can click in the 
field and enter a number.

To enable the Autoselect feature, click the checkbox next to the label. 
When enabled, the Autoselect feature will automatically highlight the 
first document in a Search Results list.

Figure 4.25

Desktop Configuration 
Screen
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Exporting the Registry File

After you have set the PowerDOCS Configuration options that you 
wanted to modify, you can distribute this master registry file to desktop 
users.

1. Return to the Implementation Tool Welcome Screen.

2. Click Export.

3. Select a file location for the registry file and name the file. Click 
Save.

If you do not want to include the registry file in the PowerDOCS Install 
directory or if you are providing a new registry file to your users, users 
should perform the following steps.

1. Close PowerDOCS.

Figure 4.26

PowerDOCS Imple-
mentation Tool Wel-
come Screen

N O T E You can save the registry file to the PowerDOCS Install directory
and the file will be imported to the registry as part of the
PowerDOCS installation process.
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2. On the Windows taskbar, select Start>Run.

3. Enter regedit in the field and click OK. The Windows Registry 
Editor will appear.

4. Select Registry>Import Registry File.

5. Select the master Registry file that was exported from the 
Implementation Tool. Click Open.

6. A confirmation message will appear, verifying that the file was 
imported successfully. Click OK.

7. Close the Registry Editor.



EXPORTING THE REGISTRY FILE

78 

4



C h a p t e r

5
Uninstalling DOCSFusion and

PowerDOCS Components

In This Chapter

This chapter describes how to remove DOCSFusion and 
PowerDOCS components from your system. All components 
can be removed in the same manner.
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The Uninstall Procedure

As an example of uninstalling components, the following 
procedure describes how to uninstall the DOCSFusion Client API.

1. From the Start menu, select Settings>Control Panel. The 
Control Panel appears. 

N O T E If you are uninstalling DOCSFusion, we recommend that you shut
down the DOCSFusion Windows NT service before uninstalling.
You can do this using the DOCSFusion ServerManager program or
the Services program in the Windows NT Control Panel.

Figure 5.1

Windows 98 Control 
Panel
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2. Double-click the Add/Remove Programs icon. The Add/
Remove Programs Properties dialog box appears.

3. Select PC DOCS Inc. DOCSFusion Client API V3.5.1 and click 
Add/Remove. For some Fusion family products, the Confirm 
File Deletion dialog box appears. 

Figure 5.2

Add/Remove Programs 
Properties dialog box

Figure 5.3

Confirm File Deletion 
dialog box



4. Click Yes. The Remove Programs From Your Computer 
dialog box appears. 

Figure 5.4

Remove Programs From 
Your Computer dialog 
box
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5. A number of installed files may be marked as shared. For 
each of them the Remove Shared File? dialog box appears. 

In most cases, it is safe to remove the shared file, but you 
will not cause any problem if you choose not to remove it. 
Use the Yes To All or No To All buttons to prevent the 
dialog box from appearing multiple times.

Figure 5.5

Remove Shared File? di-
alog box



6. When the uninstall is finished, the following dialog box 
appears.

In most cases, the elements referred to in the Remove 
Programs From Your Computer dialog box are shortcuts 
you may have created or moved after performing the 
original installation. It will cause no problem to leave them 
in place. 

You will be asked to reboot your machine to complete the 
uninstall process.  It is strongly recommended that you 
follow these instructions.

Figure 5.6

Remove Programs 
From Your Computer 
dialog box

N O T E Prior to uninstalling PowerDOCS, it will be necessary to remove the
PowerDOCSFooter macros that may have been installed on the
computer. See “Unintegrating the Microsoft Word Macros” on page
123.
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Configuring Application

Integration for PowerDOCS

In This Chapter

This chapter explains the steps necessary to configure and use 
applications with PowerDOCS. These steps assume that you already 
have a DOCS Open library set up. If you do not, see Chapter 8, “Library 
Maintenance,” of the DOCSFusion Setup and Administration Guide.
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Steps Necessary to Set Up Application Integration 
with PowerDOCS

1. Determine whether the applications you want to set up with 
PowerDOCS are integrated using Interceptor, Passive Integration 
or ODMA (Open Document Management API). See “Integration 
Methods” on page 87, to determine how your applications are 
integrated.

2. Use Application Maintenance to add launch methods for 
applications that will use new DDE (Dynamic Data Exchange) 
settings with PowerDOCS. See “Applications Using DDE Settings” 
on page 90, for which applications need new launch methods for 
use with PowerDOCS. 

3. If you want to integrate applications that use ODMA, see 
“Integrating Applications with ODMA” on page 120.

4. If you want to integrate applications that use Interceptor, see 
“Integrating Applications with Interceptor” on page 124.

5. After you have turned on the applications in Interceptor that you 
want your users to have access to, see “Exporting the Interceptor 
Settings” on page 133, for sharing those settings with your users.

I M P O R T A N T It is strongly recommended that you not use Application Integration
with PowerDOCS and DOCS Open on the same workstation.
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Integration Methods

There are several ways to integrate applications with PowerDOCS:

• Interceptor—an integration method that monitors when Open and 
Save dialog boxes are called.  Applications monitored through 
Interceptor should be set to Full Integration , see Chapter 8, 
“Library Maintenance,” of the DOCSFusion Setup and 
Administration Guide.

• ODMA—a Document Management integration method built into 
applications by their vendors. Applications integrated through 
ODMA in DOCS Open 3.8 are also integrated using ODMA in 
PowerDOCS. Applications set to Full Integration in DOCS Open 
3.8 Application Maintenance use Interceptor with PowerDOCS.

• Directory Monitoring—a method that tracks documents created in 
non-integrated applications and prompts you to profile them on 
returning to PowerDOCS. To set up an application to use Directory 
Monitoring, see Chapter 8, “Library Maintenance,” of the 
DOCSFusion Setup and Administration Guide.

• Passive Integration—a new integration method that allows you to 
profile Microsoft Word, Microsoft Excel, Microsoft Project 98, and 
Adobe Acrobat 4.0 documents in PowerDOCS or bypass 
PowerDOCS and save in the native application.  For more 
information on Passive Integration, see Chapter 8 of the 
PowerDOCS User’s Guide.
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Tables A.1 through A.3 list the applications that use Interceptor, Passive 
Integration, and ODMA.

Table A.1 Tested Applications- Interceptor 

Table A.2 Tested Applications - Passive Integration

Integrated Using Interceptor

Adobe Acrobat Exchange 3.0.x

AutoCad R14

Microsoft Excel 97

Microsoft Excel 2000

Corel Presentations 9.0

Corel Quattro Pro 9.0

Integrated Using Passive 
Integration

Microsoft Word

Microsoft Excel

Microsoft Project 98

Adobe Acrobat 4.x
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Table A.3 Tested Applications - ODMA

Integrated Using ODMA

Corel Presentations 8.0

Corel Quattro Pro 8.0

Corel WordPerfect 9.0

Corel WordPerfect 8.0

Microsoft PowerPoint 2000

Microsoft PowerPoint 97

Microsoft Word 2000

Microsoft Word 97
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Applications Using DDE Settings

To set up certain applications with PowerDOCS, you must create an 
additional set of launch methods to enter new Dynamic Data Exchange 
(DDE) settings used with PowerDOCS. For example, if you have a 
launch method for Excel already set up in Application Maintenance for 
use with DOCS Open, you need to create a new launch method for use 
with PowerDOCS that is identical to the original launch method except 
for the new DDE settings. You may want to change the description field 
to “Excel - PowerDOCS,” to differentiate between the two launch 
methods. 

The applications that require new DDE settings are:

• Adobe Acrobat Exchange 3.0.x

• Microsoft Excel 

• Microsoft Word

• Microsoft PowerPoint 

• Corel WordPerfect 8.0 and 9.0

• Corel Presentations 8.0 and 9.0

• Corel Quattro Pro 8.0 and 9.0

• Acrobat 4.0x

• Acrobat Reader 4.0x

N O T E Before integrating applications with PowerDOCS, verify that the
application settings listed in Library Maintenance match those
shown in the section entitled “DDE Settings for Specific
Applications.”

Corel Suite applications that are being integrated on Windows
2000 systems are configured slightly different. Refer to “Integrating
Corel Suite Applications on Windows 2000 Systems.”
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To create the additional launch methods:

1. From the Windows Start Menu, select Programs>DOCSFusion 
Services>DOCS Admin Tools>Library Maintenance.

2. Double-click the Applications icon.

3. From the Application Maintenance Select dialog box, highlight the 
application that needs an additional PowerDOCS launch method 
and click OK.

4. Click Launch Methods from the Application Maintenance dialog 
box.

5. Select a launch method and click Copy.

6. In order to differentiate between the DOCS Open launch method 
and the PowerDOCS launch method, edit the Launch Method 
Description to refer to PowerDOCS. For example, edit the Excel 
8.0 Launch Method Description as “Excel 8.0 - (PowerDOCS).” 

7. Click DDE Settings. 

8. Specify the new DDE settings, listed in Table A.4 through Table 
A.29, in the Application DDE Settings dialog box. 

For more instructions on setting up applications in Application 
Maintenance, see Chapter 8, “Library Maintenance,” in the 
DOCSFusion Setup and Administration Guide. 

I M P O R T A N T You must refresh the DOCSFusion cache when changes have
been made in Library Maintenance. To do this, go to the
DOCSFusion server and access the DOCSFusion Server Manager.
Select the Caches tab and click Refresh All. The next time you
launch PowerDOCS, your changes will take effect.
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DDE Settings for
Specific

Applications

Table A.4 Acrobat Exchange 3.0.x Launch Method Settings

Acrobat Exchange 3.0.x DDE Settings - Open

Acrobat Exchange 3.0.x DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

%FULLPATH

Application Name ACROVIEW

Topic Name CONTROL

Command 1 [FileOpen(“%1”)]

Command 2 [FileOpen(“%1”)]

Application Name AIM

Topic Name AcroExch.Document

Command 1 Print

Command 2 Print
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Table A.5 Acrobat Exchange 4.0x Launch Method Settings

Acrobat Exchange 4.0x DDE Settings - Open

Acrobat Exchange 4.0x DDE Settings - Print

Integration Type ODMA Compliant

Command Line 
Parameters

%FULLPATH

Application Name ACROVIEW

Topic Name CONTROL

Command 1 [FileOpen(“%1”)]

Command 2 [FileOpen(“%1”)]

Application Name AcrobatPowerDOCSPlugin

Topic Name AcroExch.Document

Command 1 [FilePrintSilentEx("%1")]

Command 2 [FilePrintSilentEx("%1")][AppQuit]
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Table A.6 Acrobat Reader 4.0x Launch Method Settings

Acrobat Reader 4.0x DDE Settings - Open

Acrobat Reader 4.0x DDE Settings - Print

Integration Type ODMA Compliant

Command Line 
Parameters

%FULLPATH

Application Name ACROVIEW

Topic Name CONTROL

Command 1 [FileOpen(“%1”)]

Command 2 [FileOpen(“%1”)]

Application Name AcrobatPowerDOCSPlugin

Topic Name AcroExch.Document

Command 1 [FilePrintSilentEx("%1")]

Command 2 [FilePrintSilentEx("%1")][AppQuit]
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Table A.7 Microsoft Excel 97 and Excel 2000 Launch Method 
Settings 

Microsoft Excel 97 and Excel 2000 DDE Settings - Open

Microsoft Excel 97 and Excel 2000 DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

Application Name EXCEL

Topic Name SYSTEM

Command 1 [open("%1")]

Command 2 [open("%1")]

Application Name EXCEL

Topic Name SYSTEM

Command 1 [open("%1")][print?()][close()]

Command 2 [open("%1")][print?()][quit()]

N O T E To execute a Print command from the Recently Edited documents
list without a pause at the printer setup dialog box, remove the ?
from the command syntax.
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Table A.8 Microsoft Word 97 and Word 2000 Launch Method 
Settings

Microsoft Word 97 and Word 2000 DDE Settings - Open

Microsoft Word 97 and Word 2000 DDE Settings - Print 

Integration Type ODMA Compliant

Command Line 
Parameters

/ND

Application Name WINWORD

Topic Name SYSTEM

Command 1 [REM _DDE_Direct][FileOpen("%1")]

Command 2 [REM _DDE_Direct][FileOpen("%1")]

Application Name WINWORD

Topic Name SYSTEM

Command 1 [FileOpen("%1")][FilePrint 0][DocClose 2]

Command 2 [FileOpen("%1")][FilePrint 0][FileExit 2]
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Table A.9 Microsoft PowerPoint Launch Method Settings

Microsoft PowerPoint DDE Settings - Print

Integration Type ODMA Compliant

Command Line 
Parameters

%FULLPATH

Application Name AIM

Topic Name PowerPoint.Show.8

Command 1 Print

Command 2 Print
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Table A.10 Microsoft Project 98 Launch Method Settings (Passive 
Integration Only)

Microsoft Project 98 DDE Settings - Open

Microsoft Project 98 DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

Application Name WINPROJ

Topic Name SYSTEM

Command 1 [FileOpen(“%1”)]

Command 2 [FileOpen(“%1”)]

Application Name WINPROJ

Topic Name SYSTEM

Command 1 FileOpen “%1”:FilePrint 1, 32767

Command 2 FilePrint 1,32767:FileExit 0
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Table A.11 Corel WordPerfect 8.0 Launch Method Settings 

Corel WordPerfect 8.0 DDE Settings - Open

Corel WordPerfect 8.0 DDE Settings - Print 

Integration Type ODMA Compliant

Command Line 
Parameters

Application Name WPWin8_Macros

Topic Name COMMANDS

Command 1 FileOpen("%1")WPActivate

Command 2 FileOpen("%1")WPActivate

Application Name WPWin8_Macros

Topic Name COMMANDS

Command 1 FileOpen("%1")PrintFullDoc()CloseNoSav
e(1)

Command 2 FileOpen("%1")PrintFullDoc()CloseNoSav
e(1)ExitWordPerfect()
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Table A.12 Corel WordPerfect 9.0 Launch Method Settings 

Corel WordPerfect 9.0 DDE Settings - Open

Corel WordPerfect 9.0 DDE Settings - Print 

Integration Type ODMA Compliant

Command Line 
Parameters

/ddeex/smin:

Application Name WPWin9_Macros

Topic Name COMMANDS

Command 1 Display(1) FileOpen("%1") WPActivate

Command 2 Display(1) FileOpen("%1") WPActivate

Application Name WPWin9_Macros

Topic Name COMMANDS

Command 1 FileOpen("%1")PrintFullDoc()CloseNoSav
e(1)

Command 2 FileOpen("%1")PrintFullDoc()CloseNoSav
e(1)ExitWordPerfect()
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Table A.13 Corel Presentations 8.0 Launch Method Settings

Corel Presentations 8.0 DDE Settings - Open

Corel Presentations 8.0 DDE Settings - Print

Corel Presentations 9.0

To integrate Corel Presentations 9.0, you must complete the following 
steps.

1. Disable ODMA for Presentations by adding the following Keys to 
the Windows Registry:

[HKEY_CLASSES_ROOT\PRESENTATIONS]

[HKEY_CLASSES_ROOT\PRESENTATIONS\ODMA32]

2. Turn off enhanced file dialogs option for Corel Presentations 9.  
From the Presentations Menu select Tools > Settings > 

Integration Type ODMA Compliant

Command Line 
Parameters

Application Name PRESENTATIONS

Topic Name COMMAND

Command 1 ShellFileOpen(“%1”) PRActivate()

Command 2 ShellFileOpen(“%1”)

Application Name PRESENTATIONS

Topic Name COMMAND

Command 1 ShellPrintTo(“%1”)

Command 2 ShellPrintTo(“%1”) FileExit()
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Environment.  From the Options Tab, uncheck the Use enhanced 
file dialogs.

Table A.14 Corel Presentations 9.0 Open Launch Method Settings

Corel Presentations 9.0 DDE Settings - Open

N O T E Two launch method settings are needed, one for Opening a
document and one for Printing a document.

Integration Type Full Integration

Command Line 
Parameters

/ddeex

Application Name PRESENTATIONS

Topic Name COMMAND

Command 1 ShellFileOpen(“%1”) PRActivate()

Command 2 ShellFileOpen(“%1”)

Application Name PRESENTATIONS

Topic Name COMMAND

Command 1 ShellFileOpen(“%1”) PRActivate()

Command 2 ShellFileOpen(“%1”)
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Corel Presentations 9.0 DDE Settings - Print

Table A.15 Corel Presentations 9.0 Print Launch Method Settings

Corel Presentations 9.0 DDE Settings - Open

Corel Presentations 9.0 DDE Settings - Print

Application Name PRESENTATIONS

Topic Name COMMAND

Command 1 ShellPrintTo(“%1”)

Command 2 ShellPrintTo(“%1”) FileExit()

Integration Type Full Integration

Command Line 
Parameters

/ddeex /pt

Application Name PRESENTATIONS

Topic Name COMMAND

Command 1 ShellFileOpen(“%1”) PRActivate()

Command 2 ShellFileOpen(“%1”)

Application Name PRESENTATIONS

Topic Name COMMAND

Command 1 ShellPrintTo(“%1”)

Command 2 ShellPrintTo(“%1”) FileExit()



DDE SETTINGS FOR SPECIFIC APPLICATIONS

104 

A

Corel Quattro Pro 9.0

To integrate Corel Quattro Pro 9.0, you must complete the following 
steps.

1. Disable ODMA for Presentations by adding the following Keys to 
the Windows Registry:

[HKEY_CLASSES_ROOT\QPW]

[HKEY_CLASSES_ROOT\QPW\ODMA32]

2. Turn off enhanced file dialogs option for Corel Quattro Pro 9.0.  
From the Quattro Pro Menu select Tools > Settings > 
Environment.  From the File Options tab, uncheck the Use 
enhanced file dialogs.

Table A.16 Corel Quattro Pro 9.0 OPEN Launch Method Settings

Corel Quattro Pro 9.0 DDE Settings (Open) - None

N O T E Two launch method settings are needed, one for Opening a
document and one for Printing a document.

Integration Type Full Integration

Command Line 
Parameters
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Corel Quattro Pro 9.0 DDE Settings - Print

Table A.17 Corel Quattro Pro 9.0 PRINT Launch Method Settings

Corel Quatto Pro 9.0 PRINT DDE Settings (Open) - None
Corel Quatto Pro 9.0 PRINT DDE Settings - Print

Application Name QPW

Topic Name SYSTEM

Command 1 [print("%1")]

Command 2 [print("%1")]

Integration Type Full Integration

Command Line 
Parameters

/dde

Application Name QPW

Topic Name SYSTEM

Command 1 [print("%1")]

Command 2 [print("%1")]



INTEGRATING COREL SUITE APPLICATIONS ON WINDOWS 2000 SYSTEMS

106 

A

Integrating
Corel Suite

Applications on
Windows 2000

Systems

On Windows 2000 systems you must disable ODMA and modify the 
application launch methods in order to integrate Corel WordPerfect 8.0 
\ 9.0, Quattro Pro 8.0 \ 9.0, or Presentations 8.0 \ 9.0 through 
Interceptor.  All these applications require separate launch methods for 
opening and printing documents.

1. Disable ODMA for each application by adding the following Keys 
to the Windows Registry.

WordPerfect:

[HKEY_CLASSES_ROOT\WORDPERFECT]

[HKEY_CLASSES_ROOT\WORDPERFECT\ODMA32]

Quattro Pro:

[HKEY_CLASSES_ROOT\QPW]

[HKEY_CLASSES_ROOT\QPW\ODMA32]

Presentations: 

[HKEY_CLASSES_ROOT\PRESENTATIONS]

[HKEY_CLASSES_ROOT\PRESENTATIONS\ODMA32]

To make this task easier, three Registry files have been provided. 
The files are found in the Tools>PowerDOCS directory on the 
Fusion Family CD.  As the administrator, you can make a master 
registry file and provide it to your users.  Please refer to Exporting 
the Registry File in Chapter 4 of the PowerDOCS Installation 
Guide.

2. Within each application, turn off the Use Enhanced file dialogs 
option:  

In WordPerfect select Tools > Settings > Files.  Uncheck the Use 
enhanced file dialogs selection from the Document tab.  

In Quattro Pro, select Tools > Settings.  From the File Options tab, 
uncheck the Use enhanced file dialogs selection.
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In Presentations, select Tools > Settings > Environment.  From the 
Options tab, uncheck the Use enhanced file dialogs selection.

3. Go to Library Maintenance and set the application launch 
methods for each application to use Full Integration. 

4. Edit the launch methods for each application to match the 
application settings shown below.

5. Enable the launch method in Interceptor.  Refer to “Steps 
Necessary to Set Up Application Integration with PowerDOCS” on 
page 86.
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Table A.18 WordPerfect 8.0 Open Launch Method settings  

WordPerfect 8.0 DDE Settings - Open

WordPerfect 8.0 DDE Settings - Print

Description WordPerfect 8 - Open (PowerDOCS)

Command Line 
Parameters

/ddeex

OS Environment Windows/Windows NT

Integration Type Full Integration

Application Name WPWin8_Macros

Topic Name COMMANDS

Command 1 Display(1) FileOpen("%1") WPActivate

Command 2 Display(1) FileOpen("%1") WPActivate

Application Name WPWin8_Macros

Topic Name COMMANDS

Command 1 FileOpen("%1") PrintFullDoc()
CloseNoSave(1)

Command 2 FileOpen("%1") PrintFullDoc()
CloseNoSave(1) ExitWordPerfect()
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Table A.19 WordPerfect 8.0 Print Launch Method settings

WordPerfect 8.0 DDE Settings - Open

WordPerfect 8.0 DDE Settings - Print

Description WordPerfect 8 - Print (PowerDOCS)

Command Line 
Parameters

/ddeex/smin:

OS Environment Windows/Windows NT

Integration Type Full Integration

Application Name WPWin8_Macros

Topic Name COMMANDS

Command 1 Display(1) FileOpen("%1") WPActivate

Command 2 Display(1) FileOpen("%1") WPActivate

Application Name WPWin8_Macros

Topic Name COMMANDS

Command 1 FileOpen("%1") PrintFullDoc()
CloseNoSave(1)

Command 2 FileOpen("%1") PrintFullDoc()
CloseNoSave(1) ExitWordPerfect()
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Table A.20 WordPerfect 9.0 Open Launch Method settings  

WordPerfect 9.0 DDE Settings - Open

WordPerfect 9.0 DDE Settings - Print

Description WordPerfect 9 - Open (PowerDOCS)

Command Line 
Parameters

/ddeex

OS Environment Windows/Windows NT

Integration Type Full Integration

Application Name WPWin9_Macros

Topic Name COMMANDS

Command 1 Display(1) FileOpen("%1") WPActivate

Command 2 Display(1) FileOpen("%1") WPActivate

Application Name WPWin9_Macros

Topic Name COMMANDS

Command 1 FileOpen("%1") PrintFullDoc()
CloseNoSave(1)

Command 2 FileOpen("%1") PrintFullDoc()
CloseNoSave(1)
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Table A.21 WordPerfect 9.0 Print Launch Method settings

WordPerfect 9.0 DDE Settings - Open

WordPerfect 9.0 DDE Settings - Print

Description WordPerfect 9 - Print (PowerDOCS)

Command Line 
Parameters

/ddeex/smin:

OS Environment Windows/Windows NT

Integration Type Full Integration

Application Name WPWin9_Macros

Topic Name COMMANDS

Command 1 Display(1) FileOpen("%1") WPActivate

Command 2 Display(1) FileOpen("%1") WPActivate

Application Name WPWin9_Macros

Topic Name COMMANDS

Command 1 FileOpen("%1") PrintFullDoc()
CloseNoSave(1)

Command 2 FileOpen("%1") PrintFullDoc()
CloseNoSave(1)
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Table A.22 Presentations 8.0 Open Launch Method settings  

Presentations 8.0 DDE Settings - Open

Presentations 8.0 DDE Settings - Print

Description Presentations 8 - Open (PowerDOCS)

Command Line 
Parameters

/ddeex

OS Environment Windows/Windows NT

Integration Type Full Integration

Application Name PRESENTATIONS

Topic Name COMMAND

Command 1 ShellFileOpen("%1") PRActivate()

Command 2 ShellFileOpen("%1")

Application Name WPWin9_Macros

Topic Name COMMANDS

Command 1 ShellPrintTo("%1")

Command 2 ShellPrintTo("%1") FileExit()
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Table A.23 Presentations 8.0 Print Launch Method settings  

Presentations 8.0 DDE Settings - Open

Presentations 8.0 DDE Settings - Print

Description Presentations 8 - Print (PowerDOCS)

Command Line 
Parameters

/ddeex/pt

OS Environment Windows/Windows NT

Integration Type Full Integration

Application Name PRESENTATIONS

Topic Name COMMAND

Command 1 ShellFileOpen("%1") PRActivate()

Command 2 ShellFileOpen("%1")

Application Name WPWin9_Macros

Topic Name COMMANDS

Command 1 ShellPrintTo("%1")

Command 2 ShellPrintTo("%1") FileExit()
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Table A.24 Presentations 9.0 Open Launch Method settings

Presentations 9.0 DDE Settings - Open

Presentations 9.0 DDE Settings - Print

Description Presentations 9 - Open (PowerDOCS)

Command Line 
Parameters

/ddeex

OS Environment Windows/Windows NT

Integration Type Full Integration

Application Name PRESENTATIONS

Topic Name COMMAND

Command 1 ShellFileOpen("%1") PRActivate()

Command 2 ShellFileOpen("%1")

Application Name WPWin9_Macros

Topic Name COMMANDS

Command 1 ShellPrintTo("%1")

Command 2 ShellPrintTo("%1") FileExit()
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Table A.25 Presentations 9.0 Print Launch Method settings

Presentations 9.0 DDE Settings - Open

Presentations 9.0 DDE Settings - Print

Description Presentations 9 - Print (PowerDOCS)

Command Line 
Parameters

/ddeex/pt

OS Environment Windows/Windows NT

Integration Type Full Integration

Application Name PRESENTATIONS

Topic Name COMMAND

Command 1 ShellFileOpen("%1") PRActivate()

Command 2 ShellFileOpen("%1")

Application Name WPWin9_Macros

Topic Name COMMANDS

Command 1 ShellPrintTo("%1")

Command 2 ShellPrintTo("%1") FileExit()
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Table A.26 Quattro Pro 8.0 Open Launch Method settings  

Quattro Pro 8.0 DDE Settings - Open

Quattro Pro 8.0 DDE Settings - Print

Description Quattro Pro 8 - Open (PowerDOCS)

Command Line 
Parameters

/ddeex

OS Environment Windows/Windows NT

Integration Type Full Integration

Application Name QPW

Topic Name SYSTEM

Command 1 {FileOpen "%1"}

Command 2 {FileOpen "%1"}

Application Name QPW

Topic Name SYSTEM

Command 1 [print("%1")]

Command 2 [print("%1")]
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Table A.27 Quattro Pro 8.0 Print Launch Method settings  

Quattro Pro 8.0 DDE Settings - Open

Quattro Pro 8.0 DDE Settings - Print

Description Quattro Pro 8 - Print (PowerDOCS)

Command Line 
Parameters

/ddeex

OS Environment Windows/Windows NT

Integration Type Full Integration

Application Name QPW

Topic Name SYSTEM

Command 1 {FileOpen "%1"}

Command 2 {FileOpen "%1"}

Application Name QPW

Topic Name SYSTEM

Command 1 [print("%1")]

Command 2 [print("%1")]
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Table A.28 Quattro Pro 9.0 Open Launch Method settings

Quattro Pro 9.0 DDE Settings - Open

Quattro Pro 9.0 DDE Settings - Print

Description Quattro Pro 9 - Open (PowerDOCS)

Command Line 
Parameters

%FULLPATH

OS Environment Windows/Windows NT

Integration Type Full Integration

Application Name QPW

Topic Name SYSTEM

Command 1 [open("%1")]

Command 2 [open("%1")]

Application Name QPW

Topic Name SYSTEM

Command 1 [print("%1")]

Command 2 [print("%1")]
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Table A.29 Quattro Pro 9.0 Print Launch Method settings

Quattro Pro 9.0 DDE Settings - Open

Quattro Pro 9.0 DDE Settings - Print

Description Quattro Pro 9 - Print (PowerDOCS)

Command Line 
Parameters

/dde

OS Environment Windows/Windows NT

Integration Type Full Integration

Application Name QPW

Topic Name SYSTEM

Command 1 [open("%1")]

Command 2 [open("%1")]

Application Name QPW

Topic Name SYSTEM

Command 1 [print("%1")]

Command 2 [print("%1")]
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Integrating Applications with ODMA

ODMA is a document management integration method built into 
applications by their vendors.

Several menu items in Microsoft Word are integrated using macros. 
Two typical examples are: (1) Insert>PowerDOCS Footer, and (2) 
Tools>PowerDOCS Mail Merge. For information on using these 
integrated menu options, see Chapter 8, “Using Applications with 
PowerDOCS,” in the PowerDOCS User’s Guide.

Installing the
Microsoft Word

Macro

1. If you have previously integrated with Word and have customized 
your DOCS Open macros, you need to rename the file 
NORMAL.DOT under a different file name. You will then have a 
backup copy of your customized macros, which can be used by a 
qualified integrator to recustomize the new macros.

2. Start Word. Select File>Open. Since Word is integrated using 
ODMA, the Search Results dialog box is displayed. If you are not 
logged in to the DOCSFusion server, the login screen is displayed. 

3. If you are installing from full integration, click Cancel to display a 
native Open dialog box. PowerDOCS displays a message box, 
asking you if you want MS Word to open a document. Click Yes to 
display the native Open dialog box. Proceed to step 5.

N O T E When installing the Microsoft Word Macros in Word 2000, macro
security must be set to medium and you must be using Word
version 9.0.32.31.

N O T E Do not start the macro by double-clicking the file in My Computer or
Windows Explorer.
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4. If you are using Passive Integration, you do not need to click 
Cancel. With Passive Integration installed, you only need to select 
File>Open to display a native dialog.

5. From the native Word Open dialog box, locate the integration 
template POWERDOCSFOOTER.DOT. The integration template is 
located in the PowerDOCS folder (by default, \Program 
Files\Pcdocs\PowerDOCS). Remember to change the Files of 
type field to Document Templates (*.DOT).

6. If you have Word set up to warn you when a document contains 
macros, the following dialog box is presented.

Click Enable Macros. 

7. A Word document appears. Click the Install Macros button at the 
bottom of the page. If the Install Macros button is not visible, 

N O T E If Native Save and Open are disabled, a native dialog box will not
appear. For additional information refer to “Restricting Users from
Using Interceptor and Native Dialog Boxes” on page 136.

Figure A.30

Word Macro Warning 
dialog box
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select Tools>Options>View from the menu bar and clear the Field 
Codes check box. 

A PowerDOCS information dialog box, like the one in Figure A.32, 
appears. Click OK. 

Figure A.31

PowerDOCS Automat-
ed Macro Installation 
Document

Figure A.32

The PowerDOCS infor-
mation dialog box 
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8. Choose File>Close. Do not save changes to the 
POWERDOCSFOOTER.DOT integration template. You should, 
however, save changes to the global template NORMAL.DOT, if you 
are prompted to do so.

This process adds global macros containing PowerDOCS function 
calls to Word's Normal template.

9. Close Word.

Unintegrating
the Microsoft
Word Macros

Prior to uninstalling PowerDOCS you must unintegrate the Microsoft 
Word Macros.

1. Start Word. Select File>Open. Since Word is integrated using 
ODMA, the Search Results dialog box is displayed. If you are not 
logged in to the DOCSFusion server, the login screen is displayed. 

2. If you are using full integration, click Cancel to display a native 
Open dialog box. PowerDOCS will ask you if you want MS Word 
to open a document. Select Yes to display the native Open dialog 
box.  Proceed to step 4.

3. If you are using Passive Integration, you do not need to click 
Cancel. With Passive Integration installed, you only need to select 
File>Open to display a native dialog.

4. Locate the integration template POWERDOCSFOOTER.DOT. The 
integration template is located in the PowerDOCS folder (by 
default, \Program Files\Pcdocs\PowerDOCS).

N O T E If Native Save and Open have been disabled, the native dialog box
will not appear.



INTEGRATING APPLICATIONS WITH INTERCEPTOR

124 

A

5. If you have Word set up to warn you when a document contains 
macros, the following dialog box is presented. 

Click Enable Macros.

6. Click the Remove Macros button at the bottom of the page.

7. Select File>Close.

8. Exit Word, saving the changes to the NORMAL.DOT template. The 
integrated menu options have been removed from your system.

Integrating Applications with Interceptor

Interceptor is installed with PowerDOCS. There are two modes that 
make up the Interceptor system: 

Figure A.33

Word Warning dialog 
box

Configuring 
Applications with 
the Interceptor 
Learning Tool

The Interceptor Learning Tool
(ILTWizard.exe) is used to set up
applications installed on the user’s
workstation for use with PowerDOCS.
The Interceptor Learning Tool is installed
in the PowerDOCS directory when you
install PowerDOCS.
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The Interceptor Module

You can use PowerDOCS Interceptor to:

• Enable or disable applications monitored by Interceptor.

• Edit Launch Method settings. 

• Export the settings to a registry file that can be run on users’ 
workstations to easily duplicate settings.

• Configure new applications.

Each of these tasks is described in the sections below. To configure a 
new application for integration with Interceptor, you can use the 
Interceptor Learning Tool (ILTWizard.exe) or configure a new 
application directly from Interceptor. For instructions, refer to 
“Configuring New Applications for Interceptor” on page 142.

Launching the
PowerDOCS
Interceptor

1. Locate the Interceptor executable, INTERCEPTOR.EXE, in your 
PowerDOCS folder (by default, \Program 
Files\Pcdocs\PowerDOCS) and double-click it. 

Configuring and 
Using Integration 
with Interceptor 

Interceptor is the module that monitors
when Open and SaveAs dialog boxes are
called for specific applications integrated
with PowerDOCS. It is represented by the
task bar icon that is displayed when the
user starts PowerDOCS.

N O T E If you are logged into PowerDOCS, the Interceptor will already be
running. If you are not logged in, the login dialog box appears.
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2. Once you are logged in to the DOCSFusion server or to 
PowerDOCS, the Interceptor program icon is displayed along the 
bottom right corner of your task bar. 

3. Double-click the Interceptor icon in the task bar. The PowerDOCS 
Interceptor dialog box appears. It contains a list of launch methods 
that are set up in Application Maintenance. The launch methods 
for the library you are logged in to are displayed by default.You can 
switch to a remote library by clicking the down arrow of the 
Library combo box. 

Figure A.34

The Interceptor icon

Figure A.35

PowerDOCS Intercep-
tor
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Enabling
Applications

Within
Interceptor

If you want to enable integration for an application within Interceptor, 
complete the following steps.

1. Launch the PowerDOCS Interceptor, as described in “Launching 
the PowerDOCS Interceptor” on page 125.

2. From the Launch Methods tab of the PowerDOCS Interceptor 
window, shown in Figure A.36, highlight the launch method for 
the application that you want to integrate and click Enable. 

Figure A.36

PowerDOCS Intercep-
tor Launch Methods tab

I M P O R T A N T If you created launch methods for the new DDE settings used with
PowerDOCS, remember to select the launch method that applies to
PowerDOCS, not DOCS Open.
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The following dialog box is displayed. 

• The Application ID and Description fields are filled in by default.

• Click the Browse button to ensure that your program path is 
correct. The Open dialog box appears. If you do not have the full 
path to the application in your system path, select the Full Path 
radio button. If this information is in your system path, you can 
accept the default of Only File Name.

Figure A.37

Launch Method Set-
tings dialog box
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• Click the down arrow of the Use settings for drop-down list and 
select the correct application from the list.

3. Click OK to enable Interceptor to monitor the application’s launch 
method. A green dot is then displayed next to the application, 
indicating that the application is now set to be monitored by 
Interceptor. 

If the Program Path on the users’ individual workstations is 
different from the Location defined in Application Maintenance, 
you need to point Interceptor to the application’s executable. For 
more information, see “Editing the Launch Method Settings” on 
page 130. 

Figure A.38

Click the Browse button 
to produce the Open di-
alog box
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Once you have enabled each application that you want integrated, 
you can create a registry file that can be run on users’ workstations 
to duplicate the integration information that you have created on 
your workstation. See “Exporting the Interceptor Settings” on page 
133.

4. Click Close to exit Interceptor.

Disabling
Integration

with
Interceptor

If you want to disable integration for an application that you have 
integrated with Interceptor, complete the following steps.

1. Launch the PowerDOCS Interceptor as described in “Launching 
the PowerDOCS Interceptor” on page 125.

2. Select the application that you want to disable from the Launch 
Methods tab of the PowerDOCS Interceptor dialog box.

3. Click Disable. The green dot to the left of the application 
description will change to a red dot indicating that the application 
launch method will no longer be monitored by Interceptor. 

Editing the
Launch Method

Settings

The Interceptor allows you to edit the path to an application that 
Interceptor will monitor. When you edit the launch method settings 
from Interceptor, your edits do not apply to Application Maintenance 
in Library Maintenance. You are only editing the path that Interceptor 
will monitor. This allows more flexibility in the location of your users’ 
integrated applications. 

For example, suppose you selected Adobe Acrobat Exchange 3.0.x to be 
monitored by Interceptor and the Location defined in the Application 
Launch Methods is:

N O T E There are some applications that require specific Launch Method
or Registry settings. Please refer to “Corel Presentations 9.0” on
page 101 and “Corel Quattro Pro 9.0” on page 104.

N O T E A yellow dot to the left of an application description means a setting
(launch method) exists in the registry but is missing or incorrect in
the database.
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 C:\Acrobat3\Exchange\AcroEx32.EXE. 

If you have DOCS Open users who have Acrobat Exchange installed on 
their D:\ drive, you would have multiple launch methods set up. In 
Interceptor, you only need to enable one of those launch methods. 
Specify only the file name of the executable in the Program Path field 
and select the Only File Name option on the Open dialog, shown in 
Figure A.38. This allows Interceptor to monitor the application 
independent from where it is launched, as long as the executable is in 
the user's search path.

To edit the launch method that Interceptor will monitor:

1. From the Interceptor dialog box, select the launch method that 
you want to edit and click Edit from the Launch Methods tab. The 
Launch Method Settings dialog box is displayed.

2. Fill out the fields as described below:

Program Path: Specify the path to the application that you want 
Interceptor to monitor. The path can be a whole or partial path or 
simply the executable file name. If you have a company whose 
individual workstations have different configurations, use the 
executable file name. Click Browse to ensure that your program 
path is correct. The Open dialog box appears, shown in Figure 
A.38. If you do not have the full path to the application in your 
system path, select the Full Path radio button. If this information 
is in your system path, you can accept the default of Only File 
Name.

Use Settings for: Select the appropriate launch method from this 
drop-down box. 

N O T E Click the Full Path button to save the information you enter in the
Program Path field.
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Interceptor
Settings

The Interceptor Settings tab of the PowerDOCS Interceptor dialog box 
contains three general settings that affect how Interceptor behaves 
when errors occur.

Open Document Notification: If this option is checked, users will 
be notified when an application format or a version 
incompatibility causes an error while opening a document. If this 
option is checked, and a conflict occurs, PowerDOCS will lock the 
document and release it only if you have selected Show Confirm 
on Releasing Document.

Show Confirm on Releasing Document: If you checked Open 
Document Notification, you must also check this option. If this 
option is checked, users will be prompted to release the document 
after the designated time if an error occurs while opening it.

Wait n seconds before releasing document: The default value is 
30 seconds. If you accept the default, PowerDOCS will try to open 
the document for 30 seconds before prompting you to release it. 
You can override the default value. 

After making these changes, you can export your settings to a registry 
file for your users. For more information, refer to “Exporting the 
Interceptor Settings” on page 133.

Figure A.39

Interceptor Settings 
tab of the Power-
DOCS Interceptor
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Exporting the
Interceptor

Settings

The Export option in the PowerDOCS Interceptor enables you to create 
a registry file that you can distribute to users to duplicate the 
application integration settings you created using Interceptor. 

Only the applications that you enabled in Interceptor before creating 
the registry file will be turned on and actively integrated in the user’s 
Interceptor.

1. Launch the PowerDOCS Interceptor as described in “Launching 
the PowerDOCS Interceptor” on page 125.

2. From the Launch Methods tab of the PowerDOCS Interceptor 
dialog box, select Export. 

3. The Export Settings dialog box appears.

4. The default setting on this dialog box is All Settings. We 
recommend that you leave this checked and click Export. The Save 
As dialog box is displayed. If you select All Settings, PowerDOCS 
assigns a default file name for the registry file of 
InterceptorSettings.reg.

• Export Settings:

Figure A.40

Save As dialog 
box
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All Settings: This option exports application settings and launch 
method settings for all applications and all libraries. This is the 
most common setting when exporting a registry file. Selecting this 
option creates a registry file named InterceptorSettings.reg, by 
default.

Only Application Settings: This option exports the settings that 
relate to application properties and creates a registry file named 
InterceptorAppDB.reg, by default.

All Launch Method Settings: This option exports only the launch 
method settings for your applications and creates a registry file 
named LaunchMethodSettings.reg, by default.

Launch Method Settings for the Selected Library: This option 
exports only the enabled launch methods for the currently selected 
library and creates a registry file named LibraryName.reg, by 
default, where your library name is inserted.

5. Select a location for the registry file and click Save. 

If you do not place the registry file(s) in the PowerDOCS folder, 
place it in a location that is accessible to all users. 

Instruct your users to double-click the registry file(s). The 
following dialog box appears, confirming that the Interceptor 
settings were installed on their workstation. 

N O T E Place the registry file in the PowerDOCS Install Kit directory (by
default, \Install\PowerDOCS), it will run automatically when
your users install PowerDOCS on their machines.

Figure A.41

Registry Editor
confirmation
message
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N O T E If the your users install PowerDOCS in a directory location that is
different from the computer from which you export the Interceptor
registry file, they may receive messages stating that there are no
valid launch methods for their applications. To resolve this issue
you should export and apply the Interceptor files in two parts:

Application Settings Only

All Launch Method Settings



RESTRICTING USERS FROM USING INTERCEPTOR AND NATIVE DIALOG BOXES

136 

A

Restricting Users from Using Interceptor and  Native 
Dialog Boxes

By design, PowerDOCS is set up to allow users to open and save files 
both within the document management system and outside the 
document management system.

If you, as the PowerDOCS Administrator, do not wish to allow the users 
and/or certain groups in your organization to save documents outside 
of PowerDOCS, you should follow the instructions listed  below. As the 
PowerDOCS Administrator, you should set up all applications via the 
Interceptor beforehand and export a registry file that can be accessed by 
the user.  See “Exporting the Interceptor Settings” on page 133.

1. Copy the DisableNativeDialogs.reg file from the Fusion 
Family CD-ROM to the ..\install\PowerDOCS directory.  
This file will be automatically merged into any workstation that 
runs the PowerDOCS Admin Kit installation program.  

This file will enable the option located in the PowerDOCS Options 
> Defaults > General tab called "Disable native dialogs".  By 
enabling this option, all native dialogs allowing you to open or 
save to the local file system will be disabled. If you plan to 
implement this feature after your users have already installed 
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PowerDOCS, you will need to instruct your users to import the 
registry file.

Figure A.42

PowerDOCS Defaults 
Dialog Box



RESTRICTING USERS FROM USING INTERCEPTOR AND NATIVE DIALOG BOXES

138 

A

3. In Library Maintenance>System Parameters and/or Groups 
Maintenance, access the Features dialog box and set the Disable Native 
Open/Save option to Yes.   

Figure A.43

Groups Maintenance>Fea-
tures dialog box
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Enabling this option will result in the following:

• The Disable Native Save checkbox located in the PowerDOCS 
Options dialog box will be unavailable for modification.

•  The Settings option in Interceptor will be unavailable.

2. As the final step, you will need to refresh the cache at the 
DOCSFusion Server Manager.  In DOCSFusion Server Manager, 
on the Caches tab, click Refresh All to update the library 
information in DOCSFusion.

Figure A.44

Library Mainte-
nance>System Parame-
ters>Features dialog box

N O T E Disabling Native Save and Open and access to Interceptor work
hand in hand. You can't disable one without disabling the other.
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3. If you wish to revert to allowing your users to save outside of 
PowerDOCS, instruct your users to run the 
EnableNativeDialogs.reg file.  You must also return to 
Library Maintenance and/or Groups Maintenance and reset the 
Disable Native Save option to No.

PowerDOCS Auto-Login

When run on a Windows 95 or 98 platform, users can save their 
PowerDOCS password to allow quick login to the system.  As an 
administrator, you can disable this feature on a global or group level.

When using PowerDOCS on a Windows NT system, the ability to save 
the PowerDOCS password is not immediately available.  As an 
administrator you can provide registry files that will allow NT users to 
save their PowerDOCS password.

Figure A.45

PowerDOCS Login dialog 
box - Windows 95 and 98

N O T E Before providing these features to your users, consider the
security issues that may result from allowing unrestricted access to
PowerDOCS.
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Disabling the
Auto-Login

Feature-
Windows 95

and 98

In Library Maintenance>System Parameters and/or Groups 
Maintenance, access the Features dialog box and set the Allow Auto 
Login to No.  Refer to Figure A.44.

Enabling and
Disabling Auto-

Login -
Windows NT

By design, the ability to save passwords for PowerDOCS  is not available 
for Windows NT users.  If your Windows NT users would like access to 
this feature, you can modify the Windows registry to allow auto-login 
by installing the registry files provided for this purpose.  The files are 
found on the Fusion Family CD in the Tools directory.

The portion of the registry that is modified is: 
HKEY_CURRENT_USER\Software\PC DOCS 

Inc.\PowerDOCS\Core\Plugins\Fusion\

The two files provided to turn this feature on and off are:

NT_Auto_Login_OFF.reg

NT_Auto_Login_ON.reg
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Configuring New Applications for Interceptor 

The PowerDOCS Interceptor allows you to integrate new applications 
that do not already exist in Interceptor’s list of launch methods. 

You can integrate new applications in one of two ways:

• Select the Application settings tab of Interceptor.

• Use the Interceptor Learning Tool Wizard (ILTWizard.exe), 
located in your PowerDOCS directory.

Integrating
New

Applications
from the

PowerDOCS
Interceptor

You can integrate a new application directly from the PowerDOCS 
Interceptor. Once you have completed the following steps, the 
application you configured will be monitored by Interceptor. You can 
disable integration with applications at any time.

Creating Launch Methods for Interceptor Applications

Before you can add and integrate a new application, you must create a 
launch method for that application in Library Maintenance. You can 
access Library Maintenance via DOCS Open or by using the DOCS 
Admin Tools.

To create a launch method for a new application:

1. From Library Maintenance, double-click the Applications icon. 

2. From the Application Maintenance Select dialog box, click the 
New button. 

3. Complete the Application Maintenance dialog box as described 
below:

Application ID: Enter an ID that is appropriate and logical. 
You will later use this ID when adding a new application to 
Interceptor.

Description: Enter the Application name in this field.

Filing Scheme: Select the appropriate filing scheme from the 
drop-down list (typically, Enhanced).
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File Types: Click the table lookup (ellipsis) button for this field 
and click Add to enter file extensions that are accepted by this 
application.

4. Click OK then click the Options button. From Application 
Options, make sure that Shows on Desktop is checked.

5. Click Close from Application Options then click the Launch 
Methods button.

6. From the Application Launch Methods Select window, click the 
New button. 

7. The Application Launch Methods dialog box appears. Complete 
this dialog box as described below:

Description: Specify the Application name in this field.

Location: Specify the drive letter and directory for this 
application. Use the table lookup (ellipsis) button to browse 
for the correct directory.

Default Directory: Specify the same drive letter and directory 
that you entered in the Location field.

Integration: Select Full Integration from this drop-down list. 
In order for Interceptor to monitor new applications, you 
must select Full Integration.

8. Click OK then click Close to return to the Application Launch 
Methods Select dialog box. Your new launch method appears in 
the Description window of this dialog box.

9. Continue to click Close until you return to the original 
Application Maintenance Select dialog box. Your new launch 
method appears in the Application ID column. 

10. Click Close and then File>Exit to close Library Maintenance.

You are now ready to add this application to Interceptor and 
should proceed with the steps in the following section. For more 
information about Library Maintenance, refer to Chapter 8, 
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“Library Maintenance,” of the DOCSFusion Setup and 
Administration Guide.

Adding New
Applications to

Interceptor

To configure a new application in the Interceptor:

1. Launch the Interceptor, using the instructions in “Launching the 
PowerDOCS Interceptor” on page 125. The PowerDOCS 
Interceptor window appears, displaying all applications that are 
currently configured to work with Interceptor. The application 
you are configuring will not appear in the list until you complete 
the subsequent steps and restart Interceptor.

2. Click the Application Settings tab. This window will be empty if 
you have never configured a new application in Interceptor. If you 
have previously integrated new applications, this list appears in the 
active window. Click Add to add a new application.

3. With the Common Properties tab selected, complete the following 
fields:

Application ID: Specify the Application ID you chose when 
creating this application’s launch method. If these Application 
IDs do not match, PowerDOCS may have trouble reconciling 
the application with its launch method.

Description: Specify the application name in this field.

Keyword: Specify the Application ID you chose when creating 
this application’s launch method. PowerDOCS attempts to 
match the value(s) in the Keyword field to words in the 
Launch Methods.

4. Click the Window Properties tab. This tab has two Autodetect 
check boxes that are selected by default. We highly recommend 
leaving these boxes checked. If you uncheck them, you will have to 
enter all application settings manually. If you leave them checked, 
Interceptor attempts to automatically detect all settings. 
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5. Click the Application Dialogs tab to display the Dialogs window. 
This window will be empty until you add commands to be 
integrated with Interceptor.

6. Click Add to display the Dialog window. Fill out the fields as 
described below.

Dialog Type: Select the dialog type that most closely matches 
the nature of the dialog box you are integrating. 

Dialog Caption: Type the caption title of the dialog box. 

Open Select this type if you want the Search 
Results dialog box presented and the 
selected document opened.

Save As Select this type if you want the Document 
Profile form displayed so the user can profile 
and save the open document. When this 
type is selected, the original document is 
replaced by the new one.

Import Select this type if you want the Search 
Results dialog box presented and the 
selected document opened into the current 
document. Some applications may not 
support Import and Export.

Export Select this type if you want the Document 
Profile form displayed so the user can profile 
and save the exported document. Some 
applications may not support Import and 
Export. When this type is selected, the 
original document remains open. This is 
useful for MS Outlook and for graphics 
programs where you want to perform a 
“Save Copy As.”
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Not full caption: Select this check box if you want to use the 
same settings for several dialog boxes with equal functionality 
and similar headings. In the Dialog Caption field, type the 
common part of the headings and select Not full caption.

Autodetect: This check box is selected by default, and it is 
strongly recommended that you leave it selected.

7. Click OK to save your settings. The dialog box you configured 
appears in the Dialogs window. You can repeat step 6 to configure 
other commands in this application.

8. When you have finished integrating commands, click OK and 
close the Application Settings dialog box.

9. Your new application should appear in the Application Settings list 
now. 

10. Select the Launch Methods tab and click Enable to allow 
Interceptor to begin monitoring this application. 

11. The Launch Methods Settings dialog box appears. Select the 
correct application in the Use Settings for field. 

Integrating
New

Applications
Using the

Interceptor
Learning Tool

The Interceptor Learning Tool is a separate component of the 
PowerDOCS Interceptor that is installed in the PowerDOCS directory. 
This executable file, ILTWizard.exe, is located in C:\Program 
Files\Pcdocs\PowerDOCS\, where C: represents your local hard 
drive. 

This tool is designed to help you configure Interceptor to accept other 
applications not currently listed in the Application Settings tab of 
Interceptor.

N O T E For further instruction on enabling applications in Interceptor, refer
to “Enabling Applications Within Interceptor” on page 127.
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Integrating an Application

The Interceptor Learning Tool is configured similar to other 
application wizards. The tool is designed to guide you through the 
entire process of configuring the desired application. In the following 
instructions, the Interceptor Learning Tool will be referred to as the ILT 
Wizard.

The example below shows how to integrate Paint Shop Pro version 5.01.

1. Using My Computer, locate the PowerDOCS directory. Double-
click ILTWizard.exe. The Welcome window appears.

N O T E Prior to setting up applications using the ILT Wizard, a Launch Method
must be created in DOCS>Library Maintenance>Applications. The
Launch Method must use Full Integration. For information on setting up
Launch Methods, refer to “Creating Launch Methods for Interceptor
Applications” on page 142.
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2. From the Welcome window, click Next. The Application 
Parameters dialog box appears.

3. Following the on-screen instructions, complete the Application 
ID, Name, and Keywords fields. 

Application ID: Type the Application ID you chose when 
creating this application’s launch method. If these Application 
IDs do not match, PowerDOCS may have trouble reconciling 
the application with its launch method.

Description: Type the application name in this field.

Keyword: Specify the Application ID you chose when creating 
this application’s launch method. PowerDOCS will attempt to 
match the value(s) in the Keyword field to words in the 
Launch Methods. Click Next.

Figure A.46

Application Parame-
ters dialog box
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4. The Select an Application dialog box appears. The application you 
are integrating must be currently open on your desktop. Our 
example uses Paint Shop Pro. You should open the application of 
your choice now.

If the application name does not appear in the Application field, 
you can use the Find Application feature to locate the application. 
The Paint Shop Pro window should be maximized in the 
background. Click Find Application. The ILT Wizard will 
minimize and a specialized cursor will appear. Click the Paint 
Shop Pro window.

Figure A.47

Select an Application 
dialog box

N O T E You may receive a message, asking you to open one document in the
MDI application before continuing. If you receive this message, press
Alt+Tab and select your application. Then click File>New or File>Open
and open a file into your application. Then press Alt+Tab to select the
ILTWizard and click Find Application again.
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The Select an Application dialog box will reappear. Paint Shop Pro 
should be listed in the Application field.

5. Verify that the correct application is selected by clicking Verify. 
The ILT Wizard window will minimize and your application 
window will be flashing. You will be asked if this is the correct 
application. Click Yes if the correct application is flashing.

6. From the Select an Application dialog box, click Next. 

7. The Dialog Configuration screen will appear. You must specify the 
application commands that you want to configure for Interceptor. 
File>Open and File>Save As are common commands to integrate 
with PowerDOCS and will be used in this example. File>Import 
and File>Export are also available. Press Alt + Tab to select Paint 
Shop Pro and click File>Open.

8. Press Alt + Tab again and select the Interceptor Learning Tool 
Wizard. “Open” should appear in the text field of the Dialog 
Configuration window. If it does not appear, click Find Dialog. 
The ILT Wizard will minimize, and a special cursor will appear. 
Click the Open dialog box. The ILT Wizard will reappear, and 
Open should be displaying in the text field.
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9. You must confirm that the correct dialog box was selected by 
clicking Verify. You will be asked if the correct dialog box is 
flashing. Click Yes if this is correct. Click Next to continue. The 
Known dialog detected window appears in the upper-right corner 
of your screen.

It will indicate if the dialog window you have configured is 
recognized by the Interceptor Learning Tool. 

10. Click Verify to confirm that the correct command will be 
intercepted. The ILT Wizard will highlight the appropriate fields of 
the dialog box you configured. You will be asked if these fields are 
correct. If you agree, click Yes. Click Next to continue and proceed 
to step 12. If the fields are not correct, click No and proceed to step 
11.

11. If the dialog box is not known to the Interceptor Learning Tool, 
click Train Again. The Configure Dialog window will appear. You 
will be instructed to click in the File Name field of the dialog box 
you are attempting to configure.

The next step is to click OK. Some applications do not have an OK 
button. In this case, the Open button represents the OK 
command. 

The last step is to click Cancel to return to the Dialog 
Configuration window. Click Verify from the Configure Dialog 

Figure A.48

Known Dialog Detected 
dialog box
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window. You will be asked if this is correct. Click Yes if you agree. 
Now click Next to continue. 

12. The Dialog Options screen appears. Make sure that the command 
you just configured is displaying in the Dialog Type field. In this 
case, the Open command should appear. If the caption of the 
dialog box is not fixed, for example, it may show a file name in 
addition to the dialog box title, click the Partial Caption check box.

If you do not want to set up additional dialog windows, click the 
second check box. If you will be configuring additional dialog 
boxes, leave this check box unmarked and click Next.

13. If you have finished integrating dialogs for this application, check 
the second check box and click Next. 

Figure A.49

Dialog Options
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14. An ILT Wizard message box will ask you if you want to view the 
application parameters that you just configured. Click Yes to view 
these. Otherwise, click No.

15. To edit any of the parameters, double-click the desired key. Edit 
the shown value and click OK. Click Next to continue. 

16. The final ILT Wizard dialog box appears, confirming that your 
application is configured. If you want to configure another 
application, click the check box at the bottom of this dialog box 

Figure A.50

Editing Parameters

W A R N I N G We strongly recommend that you not change the parameters that
you configured through the ILTWizard.
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and then click Next. If you do not want to configure another 
application, click Finish to close the ILT Wizard. 

N O T E To use the new integrated application, you must do the following:

1. Enable the integration. Refer to “Enabling Applications Within
Interceptor” on page 127. Close and restart PowerDOCS
Interceptor before using this integrated application.

2. Create a PowerDOCS launch method for this application. Refer
to “Creating Launch Methods for Interceptor Applications” on page
142.

You can export these settings for your users. Refer to “Exporting
the Interceptor Settings” on page 133 for more information.
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PowerDOCS E-Mail Integration

In This Appendix

This document describes how to configure PowerDOCS E-mail 
Integration on your system.
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Mail Client Requirements

The e-mail clients supported for PowerDOCS integration are:

• Microsoft Outlook

• GroupWise

• Lotus Notes

Outlook 98, Outlook 2000, Lotus Notes and GroupWise have been 
tested with PowerDOCS 3.1.

Microsoft  Management Console (MMC), version 1.1, must be 
installed on your computer in order to configure PowerDOCS E-mail 
Integration for Microsoft Outlook.  See “Installing the Microsoft 
Management Console” on page 45.  In addition, you should be a DOCS 
Open Supervisors Group member.

E-mail
Integration

Options

PowerDOCS E-mail Integration for Microsoft Outlook provides the 
following integration types:

• None – No integration

• Normal – Mail messages and attachments are stored in 
PowerDOCS as simple, separate documents.

• Enhanced – The most complete integration, PowerDOCS E-mail 
Integration for Microsoft Outlook allows you to search for 
documents saved from the mail. This integration method supports 
the storing of message parameters (for example: MAIL_ID, 
ATTACH_NUM, MSG_ITEM, DELIVER_REC, PARENTMAIL_ID, 

and THREAD_NUM) and requires modification in your database.

PowerDOCS E-mail Integration for Lotus Notes and GroupWise is of 
the Normal type. Additional information about Outlook, Lotus Notes 
and GroupWise integration can be found in Chapter 9 of the 
PowerDOCS User’s Guide.
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Configuring
Enhanced

Integration for
Microsoft

Outlook

Configuring PowerDOCS and MMC to support Enhanced Integration 
for Microsoft Outlook is a multi-step process.  The options can be 
configured using the Implementation Tool.  See “E-mail Integration
Configuration” on page 66.

Modifying the PROFILE Table

New SQL columns must be added to the PROFILE table and Profile 
form (dialog box). You can add these columns manually, as shown 
below or use the TBLCOMP.EXE utility.

Adding SQL Columns Using TBLCOMP.EXE

1. Access the Tools\PowerDOCS directory on the Fusion Family CD. 
Copy the EmailIntegration.tbl file into the 
...\PCDOCS\DOCSAdminTools directory.

2. From the Windows task bar click Start>Run.

In the Open field, type 
...\PCDOCS\DOCSAdminTools\TBLCOMP.EXE /
tEmailIntegration.tbl

3. Click OK.

TBLCOMP.EXE will then initialize the DOCS database, adding six  
columns to the PROFILE table.  The columns and their properties are 
as follows:

N O T E You can hide these new columns on the profile if you do not want
your users to see them.

Column Name Type Length Object Type

MAIL_ID String 80 Edit

PARENTMAIL_ID String 60 Edit

THREAD_NUM Integer - Edit

ATTACH_NUM String 20 Edit
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Next add the columns to the Profile Form. See “Modifying the Profile
Form” on page 160.

Adding SQL Columns Using DOCS Designer

1. Run DOCS Designer. For users with permission, there are three 
methods of access: from the DOCS Open Desktop, from the 
DOCS Open Admin program group, or by running the Paint32
executable file in the DOCS Open program directory. Log in to 
Designer.

2. Select Edit>Edit Data Dictionary or click the Database button on 
the toolbar. The Select Field to Edit dialog box appears.

MSG_ITEM Integer - CheckBox

DELIVER_REC Integer - CheckBox

Column Name Type Length Object Type

Figure B.1

Select Field to Edit dialog 
box
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3. Highlight the PROFILE table from the Tables column and click 
New Column. The Edit Column Description dialog box appears. 
Specify the following information for the columns below. After 
entering information in the Column Name, Type, Length, and 
Object Type fields, click OK to add that column to the column list. 
Then click New Column and enter the settings for the next 
column.

4. After all columns have been added, click Close to close the Select 
Field to Edit dialog box. 

Next add the columns to the Profile Form. See “Modifying the Profile
Form” on page 160.

Column Name Type Length Object Type

MAIL_ID String 80 Edit

PARENTMAIL_ID String 60 Edit

THREAD_NUM Integer - Edit

ATTACH_NUM String 20 Edit

MSG_ITEM Integer - CheckBox

DELIVER_REC Integer - CheckBox

N O T E You can hide these new columns on the profile if you do not want
your users to see them.
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Modifying the Profile Form

1. Select File>Open Profile Form or click the Profiles button located 
on the toolbar. The Available Forms dialog box appears.

2. Select your Profile Form from the Available Forms dialog box and 
click OK. The Designer window will open.

3. From the SQL Columns window, select each of the newly added 
columns and drag and drop them into the Profile Form design, 
placing the fields where you want them on the form. 

Figure B.2

Available Forms dialog box

N O T E You should add all columns such as MAIL_ID, PARENTMAIL_ID,
and so forth, to your Profile Form(s) and GROUP_DEF forms.

If you do not want your users to see these fields, you can adjust the
height of the Document Profile form to hide the fields.
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4. After all the new columns have been added and placed on the form 
where you want them, select File>Close. When asked if you want 
to save your changes, select Yes.

5. Close DOCS Designer.

Add the
Exchange or

Outlook E-mail
Client to the

Library

In order to properly support MSG format, you must add the e-mail 
client to the Application Library. Perform the following steps.

1. Start DOCS Open Library Maintenance. For users with 
permission, there are three methods of access: from the DOCS 
Open Desktop (choose menu item Options>System 
Utilities>Library Maintenance), from the DOCS Open Admin 

Figure B.3

Document Profile 
dialog box with new 
columns added

N O T E After the columns have been added and saved, it is necessary to
refresh caches on the DOCSFusion Server Manager program.
Refer to “Managing the Internal Caches,” in Chapter 7 of the
DOCSFusion Setup and Administration Guidefor more information
on refreshing server caches.
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program group, or by running the Docsadm.exe executable file 
located in the DOCS Open program directory. Log in to DOCS.

2. Double-click the Applications icon. The Application Maintenance 
Select dialog box appears, displaying all available launch methods.

3. Click New. The Application Maintenance dialog box appears.

4. Complete the following fields as described below:

Application ID: Enter an ID that is appropriate and logical. 
For example, enter MS OUTLOOK in this field.

Description: Enter an Application description in this field.

Filing Scheme: Select Enhanced from the drop-down list.

Default Extension Field: Type MSG in this field.

5. Click OK to enable the buttons located at the top of this dialog 
box.

Figure B.4

Application Maintenance 
dialog box



ADD THE EXCHANGE OR OUTLOOK E-MAIL CLIENT TO THE LIBRARY

CHAPTER         163

B

6. Click the Options button to display the Application Options 
dialog box. Uncheck Shows on Desktop and click OK; then click 
Close to return to the Application Maintenance dialog box. 

7. Click Launch Methods. The Application Launch Methods Select 
dialog box appears.

8. Click New. The Application Launch Methods dialog box appears. 
Enter the following values in the correct fields: 

Figure B.5

Applications Options dialog 
box

Field Value

Description MS OUTLOOK or MS EXCHANGE

Location <FULL PATH>\OUTLOOK.EXE (or
EXCHNG32.EXE), where FULL PATH is
the path from which you run MS Outlook
or Exchange

Command Line
Parameters

/f %FULLPATH

OS Environment Windows/Windows NT

Integration Full Integration
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9. Click Close to return to the Application Launch Methods Select 
window. The launch method you just created for Outlook should 
now appear in this window. Continue to click Close until you have 
exited Library Maintenance.

Now you can start PowerDOCS so that it recognizes the new 
application. The application will not show on the PowerDOCS 
Desktop, because you unchecked that option in Figure B.5.

Customizing
Outlook E-mail

Integration
Settings

PowerDOCS e-mail integration settings for Microsoft Outlook are 
modified through the PowerDOCS Implementation tool.  Refer to “E-
mail Integration” on page 66.

Figure B.6

Application Launch 
Methods dialog box for 
Outlook 98
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Microsoft Outlook Client

The Outlook Client for PowerDOCS allows PowerDOCS users to 
access their document libraries while using Microsoft Outlook.  When 
this option was selected during PowerDOCS client installation,  you 
need to install the PowerDOCS service to enable the client.  This must 
be done on every desktop installation.

1. Launch Microsoft Outlook. If necessary, log in to PowerDOCS.

2. Select Tools, Services. The Services dialog box will appear.

If PowerDOCS is not listed as a service, click Add.

Figure B.7

Services Dialog
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3. The Add Service to Profile dialog will display. Select PowerDOCS 
and click OK.

4. Close Outlook and reopen the application.  The user will be 
prompted to log in to PowerDOCS.  Logging in to PowerDOCS is 
necessary if the user wants to use the PowerDOCS Client during 
this Outlook session.

Additional information about the Outlook Client is found in 
Chapter 9 of the PowerDOCS User’s Guide.

Figure B.8

Add Service to Dialog
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5. Click OK to close the Services dialog. The PowerDOCS folder will 
appear in the Folder List, shown in Figure B.9.

For information on using the Microsoft Email Client, refer to Chapter 
8 of the PowerDOCS User’s Guide.

Figure B.9

Microsoft Outlook 
Folder List view

N O T E If the Folder List view is not visible, select View>Folder List
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DOCSFusion Security Regeneration

Tool

In This Appendix

This appendix describes the function and use of the DOCSFusion 
Security Regeneration tool.
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Security Regeneration

When an organization must recover documents from backup (as 
opposed to their DOCSFusion archive), file-level trustees are often lost. 
The Security Regeneration utility provides a method for reapplying the 
trustees. The utility can also be used when a user leaves your 
organization and you want to give a new user rights to his or her 
documents. 

The Security Regeneration utility checks the network-operating-
system (NOS)-level security of documents to verify that security at the 
NOS level is the same as the access rights assigned on the document 
profile. It does this by selecting each profile from the database and 
reapplying security at the NOS level for each version of that profile’s 
document. To avoid checking every document, the utility processes 
only documents selected from the Search Results dialog box. Simply 
perform a profile search on any documents for which you need security 
regenerated, and run the utility.

The Security Regeneration utility is run from the PowerDOCS 
Desktop. The PowerDOCS user must be a member of 
DOCS_Supervisors in order for Security Regeneration to appear on the 
menu.

To run the Security Regeneration utility:

1. Perform a profile search to obtain a list of the documents for 
which you want to reapply file-level security. 

2. Select the documents you wish to apply security to.  Use Shift-
Click to select consecutive documents, Ctrl-Click to select 
adjacent documents.

3. With the search results displayed in the Quick Retrieve dialog box, 
choose Options>Security Regeneration.

4. Enter a time for the utility to begin processing, or leave the field 
“Time to start processing” blank to start processing as soon as you 
click OK. Because the utility generates heavy document-server 
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activity, we recommend that you run it when demands on the 
document server are low. Click OK. 

5. When the utility is finished, click OK.  

N O T E If you are prompted to log in to other libraries or document servers, do
so as an administrator or supervisor who will have access to all files
and directories being processed.
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